Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

SataRaid help needed on install for Redhat enterprise ES/AS

kingkennyb
Occasional Contributor

SataRaid help needed on install for Redhat enterprise ES/AS

My Original Thread is actually on the following link:

http://www.linuxquestions.org/quest...p;pagenumber=14

I have the same problem as the guy below.....

Hello everyone, I am new to Linux, so please be gently and over-explain everything for me.
I read this entire thread (and others) but am still having trouble.
I am trying to install RedHat 9 on a Supermicro X5DAL-TG2 motherboard with dual SiI3112A SATA controllers.
I followed both the instructions on the Redhat linux drivers located here
ftp://ftp.supermicro.com/driver/SAT...e/Linux/Redhat/
and tried the drivers from SiI thmselves.
Neither work.
When I install do the
" linux dd hde=noprobe hdg=noprobe hdi=noprobe hdk=noprobe "
as per the instructions, but then once it gets to looking for drivers, it says none found, so I say look on floppy, and it searches it, but then says none found.
So I choose manual, choose the driver, but then it says no driver loaded...
I tried over and over, but the same result every time!!
I must be doing something wrong, just dont know what.

I even tried saying OK.. and going past no driver loaded, but then (of couse) no HD's are found.

Please, if someone could give me detailed (and I mean detailed) instructions on how to install RedHat9, I would be forever in your debt.
The HD's being used are 2SATA Maxtor 120GB, trying for a Striped Raid.

__________________________________________________
_______

Well.....I have a Abit NF7-S v2.0 running 2 maxtor 80g drives with Win XP loaded in Raid 0 striped using the Silicon Image SataRaid Sil3112 controller.

I initially left 10 gig free at the start for linux and used P/magic to format it as Linux ext2 - as later I planned to install Linux.

I now have R/Hat enterprise ES/AS v3. which I think is version 9.1 with a kernel on 2.4.21

I have also downloaded the linux driver from the S/Image site. Used the rawwrite on the initial 1st RH boot CD and created a disk via the sil.img.

Now I have read.....and read.... and read for the last 4 days loads of forums on this - and now I dont have a clue what I need to do?

The R/Hat info from S/image says it supports R/Hat 9 and above.

Before I did this it did find drives known as hde and hdg but it states - The partition table on device HDE was unreadable. Do you wanna initialize loosing all data on this drive. I say no and it says the same for hdg and then - An error has occured No valid devices found to create new filesystems.

Regardless of what I do - linux dd hde=no probe etc... it still cannot see the drives (as one...)

I can see what I think is the module as per from the floppy that I created. It shows as SIL IMAGE 6512 Sataraid Controller.....yet no drivers can be found for this.

Again...if I continue I do get the same above msg - but only for hdg? is linux now seeing both drives as one hence hdg and no hde?

If I choose YES - will it wipe the disk and loose my windows XP system?

I have even manged to get to the CLT ALT F2 and mount the floppy and run what its states in the Sil Image Red Hat FULL INSTALL notes 'sh redhat_9.0_update_boot_loaders.sh' etc......

But then it goes on to say that I need a boot disk? or use GRUB?

Gotta say - as a newbie... this stuff appears well complicated.

Can anybody advise on what I need to do. I have read millions of forums regarding Vanilla Kernels and Medley stuff.....but i cannot even get a driver to load let alone build a bloody new kernel! lol

Any advise.... help....instructions would be greatly appeciated. I was so looking forward to learning linux, but at the mo....not having much luck or understanding of this system.

Cheers,

Kingkenny

P.S The controller I have on my B/Board is the 3112. The above shows as
SIL IMAGE 6512 Sataraid Controller. Is that normal?

3 REPLIES
Stuart Browne
Honored Contributor

Re: SataRaid help needed on install for Redhat enterprise ES/AS

The drivers supplied by various hardware vendors for Linux are *VERY* specific to a kernel.

RH9's kernel is very different from RHES3's kernel, and thus drivers are not interchangerable.

If you have RH9 drivers, you'll need to use RH9 unless S/Image can supply RH ES/3 drivers for you.
One long-haired git at your service...
kingkennyb
Occasional Contributor

Re: SataRaid help needed on install for Redhat enterprise ES/AS


Thanks for the reply....Much appreciated.

I kinda guessed it was something like that.
what about installing it on a standard IDE disk... and then maybe creating a new boot disk? or Kernel incoporating the open source Silicon image drivers?

Is that something that would work? or am I just blabbing on. Sorry.

For example. When installing windows u can use a standard IDE drive and once loaded - add the SATA 150 drives. load the drivers and then windows can see em - hence allowing u to partion them accordingly

Would that theory work with linux?

Otherwise... yeah I'll wait till the release the next drivers for RH-ES/AS.




Stuart Browne
Honored Contributor

Re: SataRaid help needed on install for Redhat enterprise ES/AS

Yea, the theory will work with Linux as well.

Install onto a flat IDE disk, get the drivers compiled, and installed.

Once done, the SATA container should be available to partition.
One long-haired git at your service...