General
cancel
Showing results for 
Search instead for 
Did you mean: 

Sendmail forwarding messages just for root

SOLVED
Go to solution
c4team
Occasional Visitor

Sendmail forwarding messages just for root

After loading a set of latest Quality Pack Patches on my up-ux11i system, I started having problems with the forwarded messages to my exchange server using sendmail.

The .forward is sending rigth to my Exchange server but just for root, not for users...

If I check the logs I can see the users are using the mailer=local instead of using the esmtp as root does. so the mail just goes to its unix mail but is not being forwarded.

I did a sendmail with -v to trace the routing and it says...
forward: /home/eds/pzgmqv/.forward.cadhp082: World writable directory
pzgmqv... Connecting to local...
pzgmqv... Sent

Thanks in advance for the help!!
5 REPLIES
Sanjay_6
Honored Contributor

Re: Sendmail forwarding messages just for root

Hi,

check for sendmail permissions,

# ll /usr/sbin/sendmail
-r-sr-sr-t 1 root mail 1339392 Aug 26 2004 /usr/sbin/sendmail

Hope this helps.

regds
c4team
Occasional Visitor

Re: Sendmail forwarding messages just for root

Actually I did review all the sendmail related files according to a Thread posted here and they seem correct, including the file you suggested.

Any clue?? Thanks!!!
Joel Girot
Trusted Contributor
Solution

Re: Sendmail forwarding messages just for root

Hi,

"forward: /home/eds/pzgmqv/.forward.cadhp082: World writable directory"
In your .mc sendmail configuration file have you something like :
define(`confDONT_BLAME_SENDMAIL',`ForwardFileInGroupWritableDirPath')dnl

Regards
c4team
Occasional Visitor

Re: Sendmail forwarding messages just for root

Yes!it was something with the "DontBlameSendmail", so after trying with different options ...It worked!!

This is how it finally works:
DontBlameSendmail=ForwardFileInUnsafeDirPath

Great debbuging skills!! Thank you very much! :-)
c4team
Occasional Visitor

Re: Sendmail forwarding messages just for root

Thanks for having this forum available! it worked great for me!