Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
cancel
Showing results for 
Search instead for 
Did you mean: 

Sendmail response time

SOLVED
Go to solution
Hai Nguyen_1
Honored Contributor

Sendmail response time

Hi Folks,

I have just applied the patch PHNE_24419 to bring sendmail from 8.7 to 8.9.3 on rp7400 running 11.0. Now I notice that it will take about 2-3 minutes to start sendmail manually. In addition, mailq takes a similar amount of time to run even though the queue is empty.

There was no error/warning when I installed the patch. Where do you think the problem lies? Thanks.

Hai
2 REPLIES
Jeff Schussele
Honored Contributor
Solution

Re: Sendmail response time

Hi Hai,

Did you make a backup copies of the sendmail.cf & .cw files? If so you need to get the customizations back into them. SendMail upgrades frequently overwrite these files.
Secondly I'd check you name resolution on this host to make sure all relavent hosts resolve OK & in the normal timeframe.
Thirdly definitely look over the mail.log file for any errors/warnings.

HTH,
Jeff
PERSEVERANCE -- Remember, whatever does not kill you only makes you stronger!
Hai Nguyen_1
Honored Contributor

Re: Sendmail response time

Jeff,

THanks for your help.

The *.cf and *.cw files did not get overwritten. The problem is related to the name resolution. My lookup order is DNS then files and in neither place, I have info on the cluster's heartbeat IPs.
As soon as I added them to /etc/hosts and reversed the lookup order (files then DNS), sendmail has worked fine.

THanks again.

Hai