General
cancel
Showing results for 
Search instead for 
Did you mean: 

Shared Memory Realm Does Not Exist

SOLVED
Go to solution
Dan Ferrell
Occasional Advisor

Shared Memory Realm Does Not Exist

hey guys,
I am installing 8.1.7 and I am getting the following error: "Shared Memory Realm Does Not Exist" Has anyone seen this before? Can anyone tell me what is causing this or give me a clue how to make it go away?

Thanks in advance...

Dan Ferrell
It is fun to make the impossible - possible
10 REPLIES
Steven Sim Kok Leong
Honored Contributor

Re: Shared Memory Realm Does Not Exist

Hi,

Is your shmem kernel parameter set to 1?

Hope this helps. Regards.

Steven Sim
Brainbench MVP for Unix Admin
http://www.brainbench.com
Email: steven@beepz.com. Homepage: https://www.beepz.com
Dan Ferrell
Occasional Advisor

Re: Shared Memory Realm Does Not Exist

I have my kernel setting set to follow the examples in the installation manual.

set shmsys:shminfo_shmmax=4924967295
set shmsys:shminfo_shmmin=1
set shmsys:shminfo_shmmni=100
set shmsys:shminfo_shmseg=10

set semsys:seminfo_semmni=100
set semsys:seminfo_semmsl=100
set semsys:seminfo_semmns=200
set semsys:seminfo_semopm=100
set semsys:seminfo_semvmx=32767
It is fun to make the impossible - possible
Steven Sim Kok Leong
Honored Contributor

Re: Shared Memory Realm Does Not Exist

Hi,

You are using Solaris OS I gather?

If you are using HP-UX, pardon me, but have you perhaps followed the kernel configuration steps for the wrong OS portion?

Hope this helps. Regards.

Steven Sim
Brainbench MVP for Unix Admin
http://www.brainbench.com
Email: steven@beepz.com. Homepage: https://www.beepz.com
Patrick Wallek
Honored Contributor

Re: Shared Memory Realm Does Not Exist

The kernel parameters you have listed are for a Sun Solaris system and those parameters reside in the /etc/system file on the Solaris machine.

HP-UX does not use the /etc/system file. To change the kernel parameters on an HP-UX system I would recommend using SAM. Go into SAM then go to 'Kernel Configuration' then go to 'Configurable Parameters'. This will give you a list of the parameters that can be altered. After you finish setting the kernel parameters to your liking you wil have to go to the Actions menu and select 'Process New Kernel'. This will rebuild your kernel, move it into place, and reboot your system.
Dan Ferrell
Occasional Advisor

Re: Shared Memory Realm Does Not Exist

Yep, I am using Solaris
It is fun to make the impossible - possible
Patrick Wallek
Honored Contributor

Re: Shared Memory Realm Does Not Exist

Ahh.....Well, just an FYI this is the databases section of the HP-UX board.

I assume that you have rebooted the system after inserting the appropriate lines into the /etc/system file?
Dan Ferrell
Occasional Advisor

Re: Shared Memory Realm Does Not Exist

yep,
I know this board is for Hp, but this is the best resource I have found for information. I was hoping I could get lucky and it could be fixed in a similar way to the Hp version.

I did reboot the machine and I still have the problem.

It is fun to make the impossible - possible
Patrick Wallek
Honored Contributor
Solution

Re: Shared Memory Realm Does Not Exist

Here's a document I found on Oracle's MetaLink site. I don't know if this helps you or not.

Bookmark
Fixed font
Go to End


Doc ID:
Note:122183.1
Subject:
ORA-27101 "Shared Memory Realm Does Not
Exist" Connecting Via Net8
Type:
PROBLEM
Status:
REVIEWED

Content Type:
TEXT/PLAIN
Creation Date:
17-OCT-2000
Last Revision Date:
29-DEC-2000
Language:
USAENG



*************************************************************
This article is being delivered in Draft form and may contain
errors. Please use the MetaLink "Feedback" button to advise
Oracle of any issues related to this article.
*************************************************************

Problem Description
-------------------

You are attempting a client connection to an 8i database via
sqlplus and receive the following errors:

ERROR:
ORA-01034: ORACLE not available
ORA-27101: shared memory realm does not exist
SVR4 Error: 2: No such file or directory

You have installed 8.1.7 on the same server in a seperate
ORACLE_HOME.

Solution Description
--------------------

1) For local (BEQ) connections:

Verify that ORACLE_SID is set and points to a valid 8.1.7
database which is up and running.

% echo $ORACLE_SID
junk

% ps -ef |grep smon
oracle 24603 1 0 15:22:51 ? 0:02 ora_smon_JUNK

In this scenario, as ORACLE_SID is case-sensitive on the Unix
platform, a database called 'junk' isn't running. The fix would
be to set ORACLE_SID correctly or to the valid instance.

% setenv ORACLE_SID JUNK

2) For remote (TCP/listener) connections:

Review the listener.ora currently used to startup the listener
and verify the ORACLE_HOME is correct for all listed 8i
databases.

If the ORACLE_HOME points to the 8.1.7 software yet the database
was created with 8.1.6 or 8.1.5, then this error can occur.


Explanation
-----------

Previously when the ORACLE_HOME or ORACLE_SID was set incorrectly,
in the 'oracle' or client user's environment, only ora-1034 was reported.

ORA-01034 "ORACLE not available"

With 8.1.7, the ora-27101 is reporting that the shared memory
key generated by the client doesn't match any currently
existing keys. This is to be expected if the ORACLE_HOME used by
the client isn't the same as the one used to startup the database
with or the ORACLE_SID is not correctly referencing the right
instance.


Additional Search Words
-----------------------

listener, tnslsnr, parameter, hashing algorithm, attach, SGA
.
Dan Ferrell
Occasional Advisor

Re: Shared Memory Realm Does Not Exist

Thanks for the help, this helped to solve my problem. Thanks again...
It is fun to make the impossible - possible
Elsie Wu
Occasional Visitor

Re: Shared Memory Realm Does Not Exist

I encountered this problem on HP-UX 11i with Oracle 8i (8.1.7). None of the previously suggested ideas helped me. Here is what fixed the problem for me:

1. Increased kernel parameter mx_thread_proc to 256 (which is the minimum recommended by the Oracle 8.1.7 installation guide)

2. Re-built the kernel.

3. Re-installed Oracle 8.1.7 with Global Database Name in the format of "XXX.YYY" (my previous, failed installation had just "XXX").

I didn't need to apply any HP-UX 11i patches or Oracle patches for this.

Good luck.