cancel
Showing results for 
Search instead for 
Did you mean: 

Show me the money (B#)

 
SOLVED
Go to solution
Alex Glennie
Honored Contributor

Show me the money (B#)

Well I'm wondering if someone can help me out on this one.

O/S : 11.00 or 11.11
H/W : J5600's J6700's or PC's*
Patch level : Dec2001
PC running Exceed vers 7.# or 6.2

The problem occurs on both O/S's and via remote or local CDE login.

How to reproduce :
test1
login to cde as normal user
open dtterm
3 yields a ?? using UK keyboard,
current shell /usr/bin/sh

test2
login to cde as normal user
open dtterm
su
3 now produces a ^a with a ~above the a character.
If I then run sh and repeat the test I get a ??
the same is true if I had used/run ksh or csh.

test3
login to cde as normal user
open dtterm
su -
3 now produces a ^a with a ~above the a character.

run sh still the ^a ? but if I run ksh or csh I get a ??

Why the apparent inconsistency wrt posix shell and the use of su - ..... thoughts welcome.




13 REPLIES 13
H.Merijn Brand (procura
Honored Contributor

Re: Show me the money (B#)

1. What's the $LANG in all the examples?
2. What's the stty setting for istrip, cs8 etc?
Enjoy, Have FUN! H.Merijn
Bill McNAMARA_1
Honored Contributor

Re: Show me the money (B#)

What font is being used?

xmodmap show anything?

xfd -fn fixed
look okay?

try opening a dtterm with a different font option?

I'll test it later, and see if I come up with anything
going for a smoke..

PS don't you think the salad hat looks like a bunch of shamrock?

PPS do people actually use CDE login from windows?

Later,
Bill
It works for me (tm)
H.Merijn Brand (procura
Honored Contributor

Re: Show me the money (B#)

Bill,

Yes, people actually are using CDE from Windows :) Here on our site, we've got 10 users running Reflection-X to connect to HP-UX 11.00/CDE
Enjoy, Have FUN! H.Merijn
Bill McNAMARA_1
Honored Contributor

Re: Show me the money (B#)

I think procura may have it.

what's the output of
# locale

The su
is probably not setting it.

Later,
Bill
It works for me (tm)
Bill McNAMARA_1
Honored Contributor

Re: Show me the money (B#)

can reproduce using RX.

on login set
Language to en_GB.iso88591

*AND*
RX > Settings > keyboard british.kmp

login:
locale still en_GB.iso88591
(same as you)
Shift 3= pound sign

su

locale still en_GB.iso88591
(different to you)
Shift 3= pound sign

su -

Locale = C
Shift 3=^a with ~


(same font)

It works for me (tm)
Alex Glennie
Honored Contributor

Re: Show me the money (B#)

I take it no one has actually reproduced this then ?

fyi I've posted this after 2 days investigation so beleive me I have checked most things you are following the same trail as I have ! What I'd find useful is has anyone first hand seen this behaviour and what are their thoughts .... it happens and it's nothing to do with locale,fonts or stty's :

explanation :

What's the $LANG -> well it's en_GB.iso88591
in a dtterm before any su's

if I su it's still en_GB.iso88591

if I su - it changes to C BUT if I add
LANG=en_GB.iso88591 in roots .profile and try again it's set correctly or same as before but still I see the result so I dont think that's relevant.

stty settings haven't changed ! they're the same in all shells ......

it's nothing to do with fonts cos if it was I would never see any ??'s not matter what shell I was using surely? and I'm not changing fontpaths directly or indirectly.
Alex Glennie
Honored Contributor

Re: Show me the money (B#)

back to top with 10 pts still on offer !
Bill McNAMARA_1
Honored Contributor

Re: Show me the money (B#)

Convert to the Euro and you won't have to worry about it anymore...! ;)

Back to the top !

Later,
Bill

It works for me (tm)
Bill McNAMARA_1
Honored Contributor

Re: Show me the money (B#)

Why don't you try setting the local via the system wide profile:
/etc/profile.

I see the 'same' problem with TZ if I move the /etc/TIMEZONE to elsewhere.

Later,
Bill
It works for me (tm)