Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

Something wrong with OS version

SOLVED
Go to solution
rustam_2
Super Advisor

Something wrong with OS version

Hi all,
I dont know why but my OS behavior is a bit strange this week. During installation Oralce i got error:
Checking operating system requirements ...
Expected result: One of 11.23
Actual Result: 11.31
Check complete. The overall result of this check is: Failed <<<<
Problem: Oracle Database 10g is not certified on the current operating system.
Recommendation: Make sure you are installing the software on the correct platform.

I installed several time from this distributive and didnt face problem like this. Why OS gives me this error now?

I dont think that i'm confusing and installing different distributive of Oracle. Anywhere does OS have problem or my Oracle's version of platform?

regards,
Rustam
15 REPLIES
Michal Kapalka (mikap)
Honored Contributor

Re: Something wrong with OS version

hi,

use this command :

./runInstaller -ignoreSyspre

mikap

Michal Kapalka (mikap)
Honored Contributor

Re: Something wrong with OS version

hi,

./runInstaller -ignoreSysPreReqs

mikap
rustam_2
Super Advisor

Re: Something wrong with OS version

Hi mikap,
i know this trouble about -ignoresysPrereqs. I even started OUI and before installing oracle i got error. I attached screen of OUI.

regards,
rustam
Michal Kapalka (mikap)
Honored Contributor

Re: Something wrong with OS version

hi,

ok but this is only a warning.

go to next.

before you start installation of the Oracle DB, check this prerequirements.

patches + kernel parameters, enviroment settings ...

mikap
rustam_2
Super Advisor

Re: Something wrong with OS version

mikap,
i checked log file and found this error line:
>>>
INFO: Start output from spawned process:
INFO: ----------------------------------
INFO:
INFO: rm -f ntcontab.*
INFO: (if [ "compile" = "compile" ] ; then \
/u01/app/oracle/product/10.2.0/db_1/bin/gennttab > ntcontab.c ;\
cc +DD64 -c ntcontab.c ;\

rm -f /u01/app/oracle/product/10.2.0/db_1/lib/ntcontab.o ;\

mv ntcontab.o /u01/app/oracle/product/10.2.0/db_1/lib/ ;\

/usr/ccs/bin/ar rv /u01/app/oracle/product/10.2.0/db_1/lib/libn10.a /u01/app/oracle/product/10.2.0/db_1/lib/ntcontab.o ; fi)

INFO: Error: Demo mode has expired.
Contact your Hewlett-Packard sales office to order HP C/aC++ Developer's Bundle
INFO:
INFO: *** Error exit code 255
INFO:
Stop.
INFO: End output from spawned process.
INFO: ----------------------------------
INFO: Exception thrown from action: make
Exception Name: MakefileException
Exception String: Error in invoking target 'ntcontab.o' of makefile '/u01/app/oracle/product/10.2.0/db_1/network/lib/ins_net_client.mk'. See '/u01/app/oracle/oraInventory/logs/installActions2010-03-05_11-40-02PM.log' for details.
Exception Severity: 1

What does mean ->>
'INFO: Error: Demo mode has expired.
Contact your Hewlett-Packard sales office to order HP C/aC++ Developer's Bundle'
Should i install full\commercial version of this bundle?'

regards,
rustam
Michal Kapalka (mikap)
Honored Contributor

Re: Something wrong with OS version

Dennis Handly
Acclaimed Contributor

Re: Something wrong with OS version

>What does mean ->> INFO: Error: Demo mode has expired.
>Should I install full/commercial version of this bundle?

(Since that pays my salary, of course. :-)

No, you should remove your useless Eval compiler and Oracle should install.
Unless want to do C or C++ development and aren't using GNU.
rustam_2
Super Advisor

Re: Something wrong with OS version

Thanks, mikap and Dennis.

>>(Since that pays my salary, of course. :-)
So these bundles arent free? I thought many things for Unix\Linux's distributives are free :)

>>No, you should remove your useless Eval compiler
Um... how can i determine which ones useful and other useless? At least C/aC++ Developer's Bundle
is important for ORACLE therefore i cant install (appear error during installation).

>> aren't using GNU
what does it mean?

regards,
rustam
Michal Kapalka (mikap)
Honored Contributor
Solution

Re: Something wrong with OS version

Hi rustam,


Um... how can i determine which ones useful and other useless? At least C/aC++ Developer's Bundle
is important for ORACLE therefore i cant install (appear error during installation).

- if you have evulotion/trial licensed sw, and the test period is over, the software is no usable,
so just remove the bundle, and it should be possible to install you Oracle DB.

FYI : HP C/ANSI C developer's bundle Developer & Solution Partner Program (DSPP)

http://h21007.www2.hp.com/portal/site/dspp/menuitem.863c3e4cbcdc3f3515b49c108973a801/?ciid=4b080f1bace021100f1bace02110275d6e10RCRD


mikap
Dennis Handly
Acclaimed Contributor

Re: Something wrong with OS version

>how can I determine which ones useful and other useless? At least C/aC++ Developer's Bundle is important for ORACLE therefore I can't install (appear error during installation).

And expired Eval compiler is useless because you get that error and the install fails.
If you remove it, the bundled C compiler should be good enough.

>>> aren't using GNU

>what does it mean?

Not using gcc or g++ compilers.
rustam_2
Super Advisor

Re: Something wrong with OS version

kampir and Dennis,
I know, if license demo period is over i cant use it. I think it's not big problem to remove s/w but
will OS have problem without this C compiler in the future?

regards,
Rustam
Dennis Handly
Acclaimed Contributor

Re: Something wrong with OS version

>will OS have problem without this C compiler in the future?

No. It can't use it since it has expired. About the only use is to link Oracle applications.

When you remove it, cc_bundled(1) then appears as /usr/bin/cc.
rustam_2
Super Advisor

Re: Something wrong with OS version

Look, i decided do like this:
if oracle could be install without this compiler and OS will be normal so i'd like to reinstall this compiler just for oracle.
I want to remove trial version and will install trial version just for install oracle.
Could u explain how to remove and install correctly again?

regard,
rustam
Dennis Handly
Acclaimed Contributor

Re: Something wrong with OS version

>I want to remove trial version and will install trial version just for install oracle.
Could you explain how to remove and install correctly again?

You can't. You have used up your trial time period and now you must purchase the product.

But just remove it and Oracle should be able to be installed.
rustam_2
Super Advisor

Re: Something wrong with OS version

Thank you, Dennis and Mikap.
I deleted trial version and could install my Oracle without problems. I'm appreciate for your advices.

Regards,
Rustam