cancel
Showing results for 
Search instead for 
Did you mean: 

Squid Question!

Tommy Chan
Occasional Contributor

Squid Question!

After I install squid and config it.
I try to run Squid:
%/usr/local/squid/bin/squid -z

FATAL: getgrnam failed to find groupid for effective group 'nogroup'
Squid Cache (Version 2.4.STABLE7): Terminated abnormally.
CPU Usage: 0.030 seconds = 0.020 user + 0.010 sys
Maximum Resident Size: 0 KB
Page faults with physical i/o: 284
Aborted (core dumped)

Anyone know what happen??

Thx a lot!
Tommy
2 REPLIES
Patrick Preuss
Trusted Contributor

Re: Squid Question!

hi,

take a look in you local /etc/group file it seams the group nogroup does not exist. try to add this group "groupadd -g 65500 nogroup or change the group that squid wants to run.

hth

regrads
-PP
Goodbye Douglas! Whereever you are now, keep your towel and don't panic.
Stuart Browne
Honored Contributor

Re: Squid Question!

This is stating that the group 'nogroup' does not exist in your /etc/group file.

You have two choices. The easiest:

groupadd -g 65535 nogroup

More complete solution:

Create a user/group for the Squid proxy, and then modify the user and group settings in the configuration file to use these values (i.e. 'groupadd squid; useradd -g squid -h /usr/local/squid squid').

Once the group exists, you should be able to re-run the 'squid -z' command to initlize the cache structure.

For more information, Go straight to the source FAQ:

http://www.squid-cache.org/Doc/FAQ/FAQ.html

Hope this helps.
One long-haired git at your service...