cancel
Showing results for 
Search instead for 
Did you mean: 

SuSE 8.2 on a Proliant 1600

SOLVED
Go to solution
David Kirk_2
Advisor

SuSE 8.2 on a Proliant 1600

Hi,

I have a Proliant 1600 with a Smart SL2 Array controller. I want to install SuSE 8.2 Professional on it.

I boot off the CD, select my language, and tell it that it will be a new installation.

It starts updating the "Installation Settings" screen and tries to look up the existing partition table but fails.

lsmod shows that cpqarray is loaded, and fdisk -l /dev/ida/c0d0 shows the current partition table. It seems that the setup program can't detect these partitions.

I have tried removing the partitions and starting again, but get the same error. I have even tried manually creating the partitions, but nothing seems to make any difference.

Does anyone know how I can install SuSE on this server?


Later

David Kirk
5 REPLIES
Vernon Brown_4
Trusted Contributor

Re: SuSE 8.2 on a Proliant 1600

I had no problem installing SuSE 9 on 2 HP computers; In my case I created the partitions with fdisk, then used

#mkfs /dev/fdxx

where fdxx is the disk partition ID, to format the partitions.

Your install may go better if you manually format with mkfs; just a thought.

Vern
David Kirk_2
Advisor

Re: SuSE 8.2 on a Proliant 1600

I gave that a go, but it didn't make any difference.

Thanks anyway.
Steven E. Protter
Exalted Contributor

Re: SuSE 8.2 on a Proliant 1600

If the array controller supports Suse you can do this. You just get the drivers for the Suse distribution from the compaq web site.

But, the number of distrbutions supported with this array are limited. I can not always see the logic in the choices made.

So use a supported distribution or don't use the array.

Sorry, Suse might not be what you want if you want to use that array.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Jeroen Peereboom
Honored Contributor
Solution

Re: SuSE 8.2 on a Proliant 1600

L.S.

I just checked the SUSE compatibility page http://hardwaredb.suse.de/showProduct.php?LANG=en_UK&searchtype=simple&product_id=21890&arch_id=&dist_id=&PHPSESSID=a728641e115b4998fdea5ee9f38e3c26

SUSE 8.0 and 8.1 fully support the Compaq Smart Array 2SL.
I don't know why 8.2 is not marked as supported. Suse didn't test it?

From similar questions on RedHat Linux and RAID controllers I learned that you may need a driver diskette. I searched but could not find such a diskette...

Other wild guesses:
- sometimes adding a startup option helps(like ide=nodma or acm..=off)
- BIOS settings?

HtH

JP
David Kirk_2
Advisor

Re: SuSE 8.2 on a Proliant 1600

Very old thread. I can't even remember if I fixed it or not.