cancel
Showing results for 
Search instead for 
Did you mean: 

Subversion error

 
Balaji Borlepawar
Occasional Contributor

Subversion error

I`v installed the Subversion tool ( subversion-1.6.5) in HP-UXB.11.31 U ia64 2941137549 server. When i`m trying to excute the svn command am getting following error.

/usr/local/bin/svn -help
/usr/lib/hpux32/dld.so: Unable to find library 'libaprutil-0.so'.
Killed

Can any one please help me out in this...
7 REPLIES 7
Robert-Jan Goossens
Honored Contributor

Re: Subversion error

Hi,

libaprutil-0.so is part of the apr_util-0.9.17 which is one of runtime dependencies for subversion.

http://hpux.connect.org.uk/hppd/hpux/Development/Libraries/apr_util-0.9.17/

Run-time dependencies: apr apr_util db expat gdbm gettext libiconv neon openssl perl zlib

Regards,
Robert-Jan
Highlighted
Balaji Borlepawar
Occasional Contributor

Re: Subversion error

Now am getting below error

/usr/local/bin/svn -help
/usr/lib/hpux32/dld.so: Unable to find library 'libneon.so'.
Killed
Robert-Jan Goossens
Honored Contributor

Re: Subversion error

Hi again,

you need to install all run time dependencies for subversion.

Run-time dependencies: apr apr_util db expat gdbm gettext libiconv neon openssl perl zlib

libneon.so is part of neon.

Regards,
Robert-Jan
boyapati
Occasional Visitor

Re: Subversion error

HI,

 

i was installed all the Run-time dependencies: apr apr_util db expat gdbm gettext libiconv neon openssl perl zlib  .

 

but even when i am running SVN , i am facing same issue .

 


# /usr/local/bin/svn
/usr/lib/hpux32/dld.so: Unable to find library 'libaprutil-0.so'.
Killed
#

 

could you please help me out .

Dennis Handly
Acclaimed Contributor

Re: Subversion error: missing run-time dependencies

>all the Run-time dependencies: apr apr_util db expat gdbm gettext libiconv neon openssl perl zlib

>dld.so: Unable to find library 'libaprutil-0.so'.

 

So where was libaprutil-0.so installed?  You may have to set LD_LIBRARY_PATH to point there.

boyapati
Occasional Visitor

Re: Subversion error: missing run-time dependencies

in our system it's installed "/usr/local/apr/lib/libaprutil-1.so "

APR versions are below .

 

apr 1.5.0 apr
apr_util 1.5.3 apr_util

 

i am not not able to find "libaprutil-0.so" .

 

now how to set .

Dennis Handly
Acclaimed Contributor

Re: Subversion error: missing run-time dependencies

You may have to create a symlink from libaprutil-0.so to libaprutil-1.so.