cancel
Showing results for 
Search instead for 
Did you mean: 

Swagentd Daemon Not Enabled!!!

SOLVED
Go to solution
johnsonjthomas
Frequent Advisor

Swagentd Daemon Not Enabled!!!

Hi

I am currently working on the performance tuning of TBB 2.2 on HPUX Itanium platform. For this purpose I am trying to install caliper on HPUX. Unfortunately I am stuck with an error which I am not able to figure out. The error is as follows:

Could not start a management session for "nitkhp01:/ake*". The system administrator for host "nitkhp01" may have disabled the
swagentd daemon or there may be a networking problem affecting the operation. If the swagentd daemon has been disabled, it can be
enabled by the system administrator on "nitkhp01" by setting the "SW_ENABLE_SWAGENTD" entry in /etc/rc.config.d/swconfig to "1" and
executing "/usr/sbin/swagentd -r".

This error was encountered while installing caliper.depot.gz file on HPUX using the command swinstall -s /path/caliper.depot.gz. We tried to enable the swagentd daemon according to how it is given but still we are facing with the same problem. Actually speaking the daemon is running all the time, somehow its not able to detect that the daemon is running. It would be very helpful if anyone could help.
22 REPLIES
Steven E. Protter
Exalted Contributor

Re: Swagentd Daemon Not Enabled!!!

Shalom,

ll /etc/nsswitch.conf

If it is not there, there are a few choices with the name nsswitch as the first part of the name.

By default, new installations of HP-UX do not have an nsswitch.conf set. You need to put one in place and then restart swagentd.

Though maybe not required, I recommend:

gunzip calilper.gz

swinstall -s /tmp/caliper.gz \*

Then run swinstall. swinstall may be able to gunzip depots, but I have never tested this.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Dennis Handly
Acclaimed Contributor

Re: Swagentd Daemon Not Enabled!!!

>SEP: Though maybe not required, I recommend:
>gunzip caliper.depot.gz
>swinstall -s /path/caliper.depot \*

Yes, it's required.

>swinstall may be able to gunzip depots

It doesn't. It can handle individual files in the depot that are already compressed but not the whole tape depot.
johnsonjthomas
Frequent Advisor

Re: Swagentd Daemon Not Enabled!!!

Hi steven,

Thanks for the quick reply.I have the latest version of HPUX (11.31) and it does not have nsswitch.conf. Where can I get the nsswitch.conf file for this purpose or what should I do in order to make such a file?

Steven E. Protter
Exalted Contributor
Solution

Re: Swagentd Daemon Not Enabled!!!

Shalom again,

cd /etc

ll nsswitch*

Pick one that meets your needs.
more, cat or vi edit them.

cp nsswitch. /etc/nsswitch.conf

Then restart the swagentd daemon

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
johnsonjthomas
Frequent Advisor

Re: Swagentd Daemon Not Enabled!!!

Hi steven

I did according to what you said.
The files present are

nsswitch.files
nsswitch.nis
nsswitch.compat
nsswitch.ldap
nsswitch.hp_defaults

I did not change anything in the files. I directly copied into /etc/nsswitch.conf and restarted swagentd daemon. Tried swinstall but still it gives the same error.

Could you tell me how to find out to what kind of client is my host configured to (I mean whether is it configured to NIS or LDAP since the corresponding nsswitch files are present)?

johnsonjthomas
Frequent Advisor

Re: Swagentd Daemon Not Enabled!!!

Hi,

I tried setting nsswitch.files as /etc/nsswitch.conf and then restarted the daemon and swinstalled it.

The errors were encountered:

ERROR: RPC exception: "Communications failure (dce / rpc)" 02/17/10 11:51:16 IST
ERROR: Could not start a management session for "nitkhp01:/". The system administrator for host "nitkhp01" may have disabled the swagentd daemon or there may be a networking problem affecting the operation. If the swagentd daemon has been disabled, it can be enabled by the system administrator on "nitkhp01" by setting the "SW_ENABLE_SWAGENTD" entry in /etc/rc.config.d/swconfig to "1" and executing "/usr/sbin/swagentd -r".
* Target connection failed for "nitkhp01:/".
ERROR:More information may be found in the daemon logfile on this target (default location is nitkhp01:/var/adm/sw/swagentd.log).
* Selection had errors.


I am totally stuck at this point since I am not able to install anything on the HPUX machine because of this problem. Any help regarding this issue would be great.
Johnson Punniyalingam
Honored Contributor

Re: Swagentd Daemon Not Enabled!!!

can you run the below command

/usr/sbin/swagentd -r
Problems are common to all, but attitude makes the difference
johnsonjthomas
Frequent Advisor

Re: Swagentd Daemon Not Enabled!!!

thats the same command as swagentd -r rite????
johnsonjthomas
Frequent Advisor

Re: Swagentd Daemon Not Enabled!!!

I tried the above command also but am getting the same error.
Kapil Jha
Honored Contributor

Re: Swagentd Daemon Not Enabled!!!

Can you stop and the restart the daemon.

BR,
Kapil+
I am in this small bowl, I wane see the real world......
smatador
Honored Contributor

Re: Swagentd Daemon Not Enabled!!!

Hi,
I don't think that .gz is the cause of this error because even a management session could not start. So the solution is to be sure that the swagentd is ok.
Look for ps -ef | grep sw
And kill all session sw. Look at the date of the swagentd. When you do a swagentd -r the date of the daemon is updated. So you could also kill the swagentd to be sure and restart it.
After that gunzip the depot and install it.
HTH
Robert-Jan Goossens
Honored Contributor

Re: Swagentd Daemon Not Enabled!!!

Hi,

Could you post your /etc/hosts and the /etc/rc.config.d/netconf file.

Regards,
Robert-Jan
Dennis Handly
Acclaimed Contributor

Re: Swagentd Daemon Not Enabled!!!

>smatador: I don't think that .gz is the cause of this error

Better to fix all of the simple problems before tackling the hard SD networking issues.
johnsonjthomas
Frequent Advisor

Re: Swagentd Daemon Not Enabled!!!

Hi Robert,

The contents of the files are as follows:

/etc/hosts

172.16.41.25 nitkhp01
127.0.0.1 localhost loopback
172.16.41.26 nitkhp01

I have attached the file /etc/rc.config.d/netconf

johnsonjthomas
Frequent Advisor

Re: Swagentd Daemon Not Enabled!!!

Hi

I have found that when executing ps -ef|grep sw, it shows that the process /usr/sbin/swagentd -r is still running and there is no swagentd daemon running. Does anyone know as to why the /usr/sbin/swagentd -r process is still runnning without starting the daemon?

Thanks
Kapil Jha
Honored Contributor

Re: Swagentd Daemon Not Enabled!!!

-r
The restart option stops the currently running daemon and restarts a new daemon. Because the swagentd daemon processes options only at startup, you must restart the daemon after you have modified any daemon options. Otherwise, the modified options have no effect.

-r only restart the daemon, what we are asking here is kill the process and restart it again.

BR,
Kapil+
I am in this small bowl, I wane see the real world......
johnsonjthomas
Frequent Advisor

Re: Swagentd Daemon Not Enabled!!!

Hi Kapil

That is exactly what I am doing. I killed the process and restart it using swagentd -r command but strangely it shows that the process running is "swagentd -r" and the daemon never starts (I mean the process "swagentd -r" is running instead of restarting the swagentd daemon).

Thanks
Dennis Handly
Acclaimed Contributor

Re: Swagentd Daemon Not Enabled!!!

>Better to fix all of the simple problems

For a gzipped file, you get different more obvious errors:
$ swlist -s $PWD/ffox_A20019ar02_ia.depot.gz
ERROR: tar: /var/tmp/ffox_A20019ar02_ia.depot.gz:
This doesn't look like a tar archive
johnsonjthomas
Frequent Advisor

Re: Swagentd Daemon Not Enabled!!!

Could anyone explain me as to why "swagentd -r" process is running and not the daemon swagentd when I give a "swagentd -r" command. I have attached the output file of "ps -ef" showing the output before executing "swagentd -r" and after executing "swagentd -r" in order to give a clear idea to what I am saying. Any help would be great.

Thanks
Dennis Handly
Acclaimed Contributor

Re: Swagentd Daemon Not Enabled!!!

>Could anyone explain me as to why "swagentd -r" process is running and not the daemon swagentd

The swagentd demon IS running. That -r is just the parm you passed.
Mine has "/usr/sbin/swagentd -r" and is working fine.

johnsonjthomas
Frequent Advisor

Re: Swagentd Daemon Not Enabled!!!

Hi,

I think the swagentd problem is solved. The problem was that there were two entries in /etc/hosts and two entries in /etc/rc.config.d/netconf. The entries were as follows:

/etc/hosts

172.16.41.25 nitkhp01
127.0.0.1 localhost loopback
172.16.41.26 nitkhp01

/etc/rc.config.d/netconf

INTERFACE_NAME[0]=lan0
IP_ADDRESS[0]=172.16.41.25

INTERFACE_NAME[1]="lan0"
IP_ADDRESS[1]="172.16.41.26"

I commented one entry in both the files and now it does not show that error. But I am encountering another error. The error is as follows

======= 02/22/10 14:02:52 IST BEGIN swinstall SESSION (non-interactive)(jobid=nitkhp01-0046)

* Session started for user "root@nitkhp01".

* Beginning Selection
* Target connection succeeded for "nitkhp01:/".
ERROR:There is currently no depot software on host "nitkhp01" at location "/var/spool/sw". Make sure that an absolute pathname is specified for location (beginning with "/").
* Source connection failed for "nitkhp01:/var/spool/sw".
WARNING: More information may be found in the daemon logfile on this target (default location is nitkhp01:/var/adm/sw/swagentd.log).
* Selection had errors.

======= 02/22/10 14:02:52 IST END swinstall SESSION (non-interactive)(jobid=nitkhp01-0046)

I checked and there is no directory called sw under /var/spool. Could anyone tell as to what is happening. Any help would be great!

Thanks
Dennis Handly
Acclaimed Contributor

Re: Swagentd Daemon Not Enabled!!!

>I am encountering another error.

See your new thread:
http://forums.itrc.hp.com/service/forums/questionanswer.do?threadId=1409538