Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
cancel
Showing results for 
Search instead for 
Did you mean: 

Switch enabled in Service Guard.

MQ'ski
Regular Advisor

Switch enabled in Service Guard.

Hi.
Following scenario.
1. Service guard works on two nodes.
2. I do:
-cmhaltpkg -n node2
-cmrunpkg -n node1
-cmviewcl shows me AUTO_RUN disabled.
Is it right???
Is it possible to set that
afer point2 AUTO_RUN is still enabled?
3. If one node fails in two node cluster. That means that AUTO_RUN changes to disabled and manual enabling is neccessary?
4 REPLIES
Peter Godron
Honored Contributor

Re: Switch enabled in Service Guard.

Marcin,
please see:
http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=861833

Towards the end it also tells you how to configure AUTO_RUN behaviour.
Steven E. Protter
Exalted Contributor

Re: Switch enabled in Service Guard.

Shalom,

Did you check the package after making your last change?

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com

Re: Switch enabled in Service Guard.

This is correct behaviour. You have manually halted the package which by design automatically does a cmmodpkg -d pkg_name
After doing the cmhalpkg/cmrunpkg steps, do a cmmodpkg -e pkg_name to re-enable it

This is different behaviour to when a node fails
My house is the bank's, my money the wife's, But my opinions belong to me, not HP!
Johnny Damtoft
Regular Advisor

Re: Switch enabled in Service Guard.

If you have used cmhaltpkg for a package that was running on the secondary node, you can also just write:

# cmmodpkg -e

This will start the package on the default selected primary node in your config.