General
cancel
Showing results for 
Search instead for 
Did you mean: 

Syntax error when forming the cluster

Jithani
Occasional Advisor

Syntax error when forming the cluster

We have configured a 2 node cluster. Server1 and server2. whole setup worked fine and redundancy also accurately happened. But suddenly, when we reboot both servers following error occured.
"Using /lib/modules/2.4.21-4 ELSmp/kernel/drivers/char/deadman.o
Deadman:1.0 minor:63

/etc/rc3.d/s99cmcluster:line 124: count=: syntax error"

OS is Linux ES 3.0
5 REPLIES
Alex Lavrov.
Honored Contributor

Re: Syntax error when forming the cluster

Can you paste lines 120-130 of /etc/rc3.d/s99cmcluster please?
I don't give a damn for a man that can only spell a word one way. (M. Twain)
Jithani
Occasional Advisor

Re: Syntax error when forming the cluster

start cmclconfd"
exit 1
fi
let count=$cout + 1
/bin/sleep 1
/bin/netstat -an | /bin/grep ':5302 '
done

#
# Start cmrunnode and log the pid to a file

I tried booting server1 early and boot server2. The cluster formed without error. I found one error in the /var/log/messees in server2, which says "/dev/cciss/c1d0p1 cannot be accessed" this is lock lun partition.
Alex Lavrov.
Honored Contributor

Re: Syntax error when forming the cluster

You have "$cout" instead of "$count". "n" is missing, so you get "let count=+1" because $cout is nt set and is empty.

Regards,
alex
I don't give a damn for a man that can only spell a word one way. (M. Twain)
Jithani
Occasional Advisor

Re: Syntax error when forming the cluster

We tried that early. But it didnt help to sort. I feel it is a problem with Lock Lun. Please help if any of you understand.
Serviceguard for Linux
Honored Contributor

Re: Syntax error when forming the cluster

First - to fix the file use one of the following:

let count=$count+1

or better:

(( count = count + 1 ))

WATCH THE SPACES - they are critical.

This is unlikely to be related to LockLUN. More likely it is due to some aspect of security not set up correctly. You hit the like with the problem only if cmconfigd is not running. To get by this first, make absolutely sure that the firewall on all nodes is off (you can fix the firewall settings later). Then (for 11.15.04 and 11.16.01) make sure that you are clear on the other security settings. Easiest is probably to put the "+" in cmclnodelist file.

Remember that these recommendations are to get by your problems and to allow an easier transition into understanding the security setup.