cancel
Showing results for 
Search instead for 
Did you mean: 

System Clock run very fast

System Clock run very fast

Is there anybody who knows why the system clock run very fast on DL580G3, with RedHat AS 4.0 intial release or any update? (xeon processor) on 32 bits the same server works fine.
14 REPLIES
Steven E. Protter
Exalted Contributor

Re: System Clock run very fast

Shalom Roberto,

1) Have the hardware checkefd.
2) Connect to an ntp time source and it will cease to be a problem.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com

Re: System Clock run very fast

Thanks for your comments, however i don't have clear the first step, could you explain me ?

Regards.

What would be another solution if the NTP server is not available?
Steven E. Protter
Exalted Contributor

Re: System Clock run very fast

Shalom and apologies,

Call HP hardware support and tell them the system clock is running to fast. The battery or system board needs to be checked.

Have them make sure system firmware is up to date.

If that does not work, pick a time server from public time sources listed at http://www.ntp.org

Here is a guide on setting up ntp on Linux.
http://www.siliconvalleyccie.com/linux-hn/ntp.htm
http://www.linuxselfhelp.com/quick/clock.html

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com

Re: System Clock run very fast

Thank you so much for the clarification, now I got it. However I don't think this is a hw proble, because the same server installed with a 32bits kernel works fine, only on 64bits. Thank you.
Steven E. Protter
Exalted Contributor

Re: System Clock run very fast

I'd still get the hardware checked, but agree with your conclusion.

Based on your clarification, I'd recommend doing a full upt2date on the system, or use yum and get every patch available for the 64 bit kernel.

I'm assuming this system is 64 bit capable, but you say its a Xeon processor, which I thought was only 32 bits. If this is so, it may explain the behavior.

Please get clarification on the hardware.

What does /etc/sysconfig/hwconf

It usually states how many bits the processor has.

Steven "I work for itrc points" Protter
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Ivan Ferreira
Honored Contributor

Re: System Clock run very fast

What is the configuration of /etc/sysconfig/clock.

Configure your correct timezone in that file.

Use:

UTC=false
ARC=false

Is very advisable to use external public NTP server.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?

Re: System Clock run very fast

Attach the hwconf, and the clock file is like this:


ZONE="America/Mexico_City"
UTC=false
ARC=false

And the cpuinfo :

processor : 0
vendor_id : GenuineIntel
cpu family : 15
model : 4
model name : Intel(R) Xeon(TM) MP CPU 3.00GHz
stepping : 1
cpu MHz : 3000.385
cache size : 1024 KB
physical id : 0
siblings : 2
fpu : yes
fpu_exception : yes
cpuid level : 5
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm pni monitor ds_cpl est tm2 cid cx16 xtpr
bogomips : 4587.30
clflush size : 64
cache_alignment : 128
address sizes : 40 bits physical, 48 bits virtual
power management:

processor : 1
vendor_id : GenuineIntel
cpu family : 15
model : 4
model name : Intel(R) Xeon(TM) MP CPU 3.00GHz
stepping : 1
cpu MHz : 3000.385
cache size : 1024 KB
physical id : 3
siblings : 2
fpu : yes
fpu_exception : yes
cpuid level : 5
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm pni monitor ds_cpl est tm2 cid cx16 xtpr
bogomips : 4587.30
clflush size : 64
cache_alignment : 128
address sizes : 40 bits physical, 48 bits virtual
power management:

processor : 2
vendor_id : GenuineIntel
cpu family : 15
model : 4
model name : Intel(R) Xeon(TM) MP CPU 3.00GHz
stepping : 1
cpu MHz : 3000.385
cache size : 1024 KB
physical id : 0
siblings : 2
fpu : yes
fpu_exception : yes
cpuid level : 5
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm pni monitor ds_cpl est tm2 cid cx16 xtpr
bogomips : 5898.24
clflush size : 64
cache_alignment : 128
address sizes : 40 bits physical, 48 bits virtual
power management:

processor : 3
vendor_id : GenuineIntel
cpu family : 15
model : 4
model name : Intel(R) Xeon(TM) MP CPU 3.00GHz
stepping : 1
cpu MHz : 3000.385
cache size : 1024 KB
physical id : 3
siblings : 2
fpu : yes
fpu_exception : yes
cpuid level : 5
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm pni monitor ds_cpl est tm2 cid cx16 xtpr
bogomips : 4587.30
clflush size : 64
cache_alignment : 128
address sizes : 40 bits physical, 48 bits virtual
power management:



I read that this server runs at 64 bits also. :-)

Regards.
rick jones
Honored Contributor

Re: System Clock run very fast

how fast is 'very fast' here? depending on how fast very fast might be, ntp may not be able to stay on top of it.

even once you have the 64-bit clock runs fast vs 32 bit issue resolved, it may be a good idea to try to get some NTP stuff going...
there is no rest for the wicked yet the virtuous have no pillows
Joel Kammet
Occasional Advisor

Re: System Clock run very fast

I don't know if this applies to your system but it's something you can check out. There is a bug in the 2.6 kernel acpi implementation which can cause the linux system clock to run fast even though the hardware clock is keeping correct time.

While booting up your computer, go into the bios setup and see if there is a setting called "FSB spread spectrum". If there is, turn it off, and this should correct the problem.
Vipulinux
Respected Contributor

Re: System Clock run very fast

Hi
Hope this helps:
http://ensode.net/no_timer_check.html


Cheers
psychollek
Occasional Visitor

Re: System Clock run very fast

i've had similar issue when upgrading the kernel not a long time ago - problem was with vesa-ng driver (or vesa in general - don't rmember exacly) - i've had to start system from my emergency disk baceuse it hadn't been even possible to log in (60 s timeout was after about 1/8 s) - try to recompile your kernel with standard vga driver
David Timms
Frequent Advisor

Re: System Clock run very fast

I saw similar thing with Fedora Core 3 (underlying technology of EL4) on a HP nx9000. This was solved by appending a kernel parameter (from memory) acpi=off or similar. This stopped the machine gaining half an hour while running for 1 hour - 1.5 hours from memory.
Vipulinux
Respected Contributor

Re: System Clock run very fast

Hi

For FC4 thsi solved the issue:
in grub.conf

kernel /boot/vmlinuz-2.6.12-1.1398_FC4 ro root=LABEL=/1 no_timer_check

Cheers

Re: System Clock run very fast

Finally the issue is fixed on the last kernel :2.6.9-22.0.2.ELsmp

No any grub change or service turned off.

Regards, thanks everybody.