Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

T5565Z i can not to pass -N on rdesktop

giorgiob
Established Member

T5565Z i can not to pass -N on rdesktop

Hello

 

I have this problem:

On my thinclient T5565z the block number for insert the ascii code on Word 2007  in rdp session not function.

The reason is because is not possibility to pass the parameter -N (Enable numlock syncronization between the Xserver and the remote RDP session) on rdesktop.

Because is not possibility pass that or othe specail parameter from the configuation of rdp connection

You can help for solve the problem.

thak you

1 REPLY
giorgiob
Established Member

Re: T5565Z i can not to pass -N on rdesktop

Hello

 

I solve my problem now I write the procedure for pass the option -N

 

  1. Enter with the administrator user an open the program X terminal in advanced tab.

    Lunch this command fsunlock

 

2. Open the program Text Editor in advanced tab and open this file : /usr/bin/rdesktop_wrapper.sh

3. Find in the file this string :

 

if [  -n "$RDP_KB"  ]; then
 OPTIONS="$OPTIONS -k $RDP_KB"

 

And add the letter -N

 

if [  -n "$RDP_KB"  ]; then
 OPTIONS="$OPTIONS -N -k $RDP_KB"

 

4. save the file close the text editor

5 Go in x-terminal and luch this commandf : fslock

6 Close x-terminal

 

Now the numlock syncronization between the Xserver and the remote RDP session is enable.

 

bye