Showing results for 
Search instead for 
Did you mean: 

TZ88 DLT on Hp-UX 11.00

Ian Lochray
Respected Contributor

TZ88 DLT on Hp-UX 11.00

I have added a TZ88 DLT to my server running HP-UX. If I try to tar to it I get the error:
tar: cannot open /dev/rmt/6m.
I have done all the obvious stuff like checking the cables etc but no joy. Browsing around I have seen posts suggesting that I need to make HP-UX think it is a DLT4000 by using the TZ882DLT utility. I found a copy of it but only for HP-UX 10.10. When I ran it I got the error:
# ./TZ882DLT /dev/rmt/c0t6d0BEST
open: I/O error
Anyone got any suggestions?
Dietmar Konermann
Honored Contributor

Re: TZ88 DLT on Hp-UX 11.00

You my need to specify a pass-through device to use the utility.

If your drive is claimed by the stape driver then the associated pt driver is sctl.

Get the major number using "lsdev -d sctl". Usually it's 203.

Then create the character device special:

# mknod /dev/rscsi/c0t6d0 c 203 0x006000

and use this for the utility. Hope, that works.

Best regards...
"Logic is the beginning of wisdom; not the end." -- Spock (Star Trek VI: The Undiscovered Country)
Ian Lochray
Respected Contributor

Re: TZ88 DLT on Hp-UX 11.00

I have now managed to run the utility by using the spt driver for the DLT tape drive. ioscan now thinks that the tape drive is a DLT4000. On the advice of an HP article, I have now removed the spt driver from the kernel and rebooted. The tape2 driver is now being used.
My problem now is that I can only tar about 100 blocks to the tape before I get the error:
Tar: end of tape
Tar: to continue, enter device/file name when ready or null string to quit.
I have cleaned the drive and changed the tape but no joy. I tried a mediainit but got:
# mediainit -v /dev/rmt/c0t4d0BEST
mediainit: initialization process starting
mediainit: this type of device unsupported
ioscan shows:
Class I H/W Path Driver S/W State H/W Type Description
tape 4 4.4.0 tape2 CLAIMED DEVICE DEC DLT4000
/dev/diag/rmt/c0t4d0 /dev/rmt/c0t4d0BEST
/dev/rmt/4m /dev/rmt/c0t4d0BESTb
/dev/rmt/4mb /dev/rmt/c0t4d0BESTn
/dev/rmt/4mn /dev/rmt/c0t4d0BESTnb

lssf shows:
# /etc/lssf /dev/rmt/c0t4d0BEST
tape2 card instance 0 SCSI target 4 SCSI LUN 0 at&t best density available at ad
dress 4.4.0 /dev/rmt/c0t4d0BEST

Can anyone help?