cancel
Showing results for 
Search instead for 
Did you mean: 

Tape Issue on Redhat AS 4

Anubhav Dhingra
Frequent Advisor

Tape Issue on Redhat AS 4

I am HP-UX guy and new to Linux. I am having issue with tape on Linux.
when i execute the command
tar tvf /dev/st0 I get the following error.

tar : /dev/st0 : Cannot read : Input/Output Error.
tar : At begining of tape :quitting now.
tar : Error is not recoverable, acuitting now.

OS : Redhat AS4,
Hardware : HP Itanium Machine and Tape Drive is DAT 72(HP)

I Have checked the drivers , they appear to be fine. please find the output of the following command.
# cat /proc/scsi/scsi
Attached devices:
Host: scsi1 Channel: 00 Id: 01 Lun: 00
Vendor: HP Model: C7438A Rev: ZP5A
Type: Sequential-Access ANSI SCSI revision:



# ls /dev/st*
/dev/st0 /dev/st0a /dev/st0l /dev/st0m /dev/stderr /dev/stdin /dev/stdout



# dmesg|grep -i st0
Attached scsi tape st0 at scsi1, channel 0, id 2, lun 0
st0: try direct i/o: yes (alignment 512 B), max page reachable by HBA 17039360
st0: Block limits 1 - 16777215 bytes.

4 REPLIES
Ivan Ferreira
Honored Contributor

Re: Tape Issue on Redhat AS 4

What is the LED status of the device?

Have you tried with another media?

You can install HP LT&T to test the device.

Is the device internally attached?

Do you have problems only reading?
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
skt_skt
Honored Contributor

Re: Tape Issue on Redhat AS 4

use cleaning tape if the drive indicates; chnage the media and try.

I had to reboot the server to get that detcted with RHEL AS4 u4 and a IBM LTO2 combination.. My case i did replace the drive and still not detcted and hence rebooted. this OS cant detect the drive online..

Anubhav Dhingra
Frequent Advisor

Re: Tape Issue on Redhat AS 4

Hi Ivan,

LEDs glow Normal, every time I insert the tapes, It initializes the tape and there LEDs are off. I tried different tapes. Device is external. I think the drivers are fine coz, Tape Drive is configured properly at the boot time. I am doubting on Block Size setting for Tape device... but not sure...
David Nixon
Valued Contributor

Re: Tape Issue on Redhat AS 4

I had a similar I/O error issue on RH AS4 when configuring a Quantum VS4 drive.

Had to provide drive-specfic initialisation parameters in /etc/stinit.def.

Have you tried the equivalent no-rewind device /dev/nst* ?