cancel
Showing results for 
Search instead for 
Did you mean: 

Telnet with Redhat 7.1

SOLVED
Go to solution
Vernon Brown_1
Frequent Advisor

Telnet with Redhat 7.1

I have 3 computers on a LAN with one running Apache as a proxy server so the two other computers surf the net. This was with Redhat 6.1. I just installed Redhat 7.1 on two. (HP Pavilion 8500's.) I can still surf the net OK with all three machines but when I try to telnet to either of the 7.1 boxes I get "Connection Refused" error messages.

Telnet always worked with Redhat 6.1 and I can telnet from either of the 7.1 machines into the remaining 6.1 machine no problem. Both of the 7.1 machines refuse telnet connections.

Is there a config file I'm missing.

Vern
6 REPLIES
Zeev Fisher
Occasional Advisor
Solution

Re: Telnet with Redhat 7.1

On RH7.1 , the remote network services are not enabled by default.

use the command ntsysv to choose the services that you want to enable ( telnet , rsh , rexec .. ) and don't forget to restart/reread the xinetd configuration.

you can do the same thing with chkconfig command.
Dave Kristol
Occasional Advisor

Re: Telnet with Redhat 7.1

Just to elaborate on the previous answer:

Telnet is insecure because your password goes over the network in the clear. Therefore Red Hat disabled telnet by default to encourage you to use ssh (secure shell). sshd, the secure shell daemon, is enabled by default on RH 7.1 systems to accept ssh connections. You use ssh pretty much the same way you use telnet, but the connection is encrypted. You use ssh's sibling program "scp" to do secure copies (in place of FTP).

Dave Kristol
Vernon Brown_1
Frequent Advisor

Re: Telnet with Redhat 7.1

Thanks guys; both answers deserve 10 points but I don't see a way to award points. How do I do it???

Vern
John Love_3
Regular Advisor

Re: Telnet with Redhat 7.1

Another option to Zeev's reply is to use the following:

chkconfig --level 35 telnet on

This will turn on telnet for run level 3 and 5 (4 is not used)

You can use chkconfig --list to list all service that are started and at what run levels. It's handy.

John
Vernon Brown_1
Frequent Advisor

Re: Telnet with Redhat 7.1

OK I found the button; didn't show up until I replied. Thanks again; I have been looking for the telnet config for a week. I didn't know about the ssh ! I'll play with it and see what I can do; Thanks.

Vern
Radhakrishnan Venkatara
Trusted Contributor

Re: Telnet with Redhat 7.1

hai , this is very simple go to /etc/xinetd.d directory there will be a file for telnet edit it using vi in that there will be line disable=yes make it no and restart the xinetd service by service xinetd restart it will start the telnet operations.

radhakrishnan
Negative thinking is a highest form of Intelligence