General
cancel
Showing results for 
Search instead for 
Did you mean: 

Trouble installing Raid controller drivers on linux on a G6

Jason Mecucci
Occasional Advisor

Trouble installing Raid controller drivers on linux on a G6

Please boot into a supported kernel before installing this rpm
error: %pre(cpq_cciss-2.6.20-23.i686) scriptlet failed, exit status 1
error: install: %pre scriptlet failed (2), skipping cpq_cciss-2.6.20-23

It lists these as the supported kernels:

SUPPORTED KERNELS:
The kernels of Red Hat Enterprise Linux 4 (x86) supported by this binary rpm are:
2.6.9-5.EL - Red Hat Enterprise Linux 4 (x86)
2.6.9-5.0.3.EL
2.6.9-11.EL - Red Hat Enterprise Linux 4 Update 1 (x86)
2.6.9-22.EL - Red Hat Enterprise Linux 4 Update 2 (x86)
2.6.9-34.EL - Red Hat Enterprise Linux 4 Update 3 (x86)
2.6.9-42.EL - Red Hat Enterprise Linux 4 Update 4 (x86)
2.6.9-42.0.3.EL
2.6.9-55.EL - Red Hat Enterprise Linux 4 Update 5 (x86)
2.6.9-55.0.9.EL
2.6.9-55.0.14.EL
2.6.9-67.EL - Red Hat Enterprise Linux 4 Update 6 (x86)
2.6.9-67.0.1.EL
2.6.9-67.0.4.EL
2.6.9-67.0.7.EL
2.6.9-67.0.15.EL
2.6.9-78.EL - Red Hat Enterprise Linux 4 Update 7 (x86)
2.6.9-89.EL - Red Hat Enterprise Linux 4 Update 8 (x86)


We're running 2.6.9-89.03

I find it hard to believe you have to run the exact version in the list, we're getting those FIFO FULL errors that this article talks about:

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01688233〈=en&cc=si&taskId=101&prodSeriesId=3821728&prodTypeId=15351

I would hope that if 2.6.9.89 was supported than 2.6.9.89.03 would be too but I suppose not. I guess we'll have to specifically go download 2.6.9.89-EL from RedHat and install that to get this driver loaded unless someone else has a newer CCISS driver than 2.6.20-23 that works with more versions of Linux. We're using RedHat AS 4u8.

Thanks,
Jason
7 REPLIES
Jimmy Vance
HPE Pro

Re: Trouble installing Raid controller drivers on linux on a G6

Just download the latest kernel from RedHat, the cciss driver is in the kernel. If the latest RHEL4 kernel doesn't have a cciss driver that supports the Smart Array controllers in the G6, you can always go to opensource.hp.com and drill down to the cciss driver. Download the latest source package and compile it against your kernel



__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Steven E. Protter
Exalted Contributor

Re: Trouble installing Raid controller drivers on linux on a G6

Shalom Jason,

I am a little confused.

G6 systems have a hardware raid systems on their built in raid cards. Just like G5, the raid is configured outside the OS and the configuration is presented to the system.

If I take two disks and configure them as raid 1, the OS sees one disk.

That scenario has proved adequate to install the OS and run the systems. The inconvenient part about it is that you can't change the configuration without booting the systems and taking down the OS.

So you are looking for OS control of this functionality?

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Jimmy Vance
HPE Pro

Re: Trouble installing Raid controller drivers on linux on a G6

Looking at the ProLiant support matrix, all the G6 systems I checked had a minimum of RHEL4.7

http://h18004.www1.hp.com/products/servers/linux/hplinuxcert.html

What G6 system and what RAID controller are you working with?



__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Jason Mecucci
Occasional Advisor

Re: Trouble installing Raid controller drivers on linux on a G6

Its a BL460C G6, and its our first G6 we've received. Normally with the G5's what we've been doing is using our kickstart which lays down RHEL4u7, with the Proliant SUpport Pack of 8.12. We have a G5 in the bunch of G6's we're setting up and it still works fine in that configuration.

However, that configuration on the G6 ends up giving us a bunch of "FIFO FULL" errors over and over, as described in the below link:

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01688233〈=en&cc=si&taskId=101&prodSeriesId=3821728&prodTypeId=15351

The supposed fix is to install the latest CCISS driver from HP (We've tried the PSP 8.25, 8.26, and downloading the CCISS driver manually, but when we try and do any of that it then complains about our kernel version when the CCISS RPM is getting installed, and it seems that we need to have the EXACT kernel listed all the way down to every .release on the support matrix. I was just curious if anyone knew of a way to get around it, or see what other solutions anyone may have had. I think we're going to just have to go download a kernel that matches on the list, because the latest one on the redhat network is a .03 release and isn't on the list.

I was just trying to see if anyone had any better ideas.

Thanks,
Jason


Jimmy Vance
HPE Pro

Re: Trouble installing Raid controller drivers on linux on a G6

from the notes in the advisory

Red Hat Enterprise Linux
This is targeted to be resolved in an errata kernel for Red Hat Enterprise Linux 4 and Red Hat Enterprise Linux 5. Until the errata kernel is available, use the HP ProLiant Smart Array Controller Driver for Linux (cciss) Version 2.6.20-16 (or later).

What version of the cciss driver is in kernel 2.6.9-89.03?

If it's not 2.6.20-16 or later your only choice right now is to download the latest cciss driver which is 2.6.20-23 (16 Jun 2009) and use the source code contained within the file to compile cciss against your running kernel.

if it is cciss 2.6.20-16 or later you need to open a support call with HP so they can track the issue and resolve.



__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Jason Mecucci
Occasional Advisor

Re: Trouble installing Raid controller drivers on linux on a G6

Yeah its not the correct versoin in 2.6.9.89.03 which is why we have to download it, and yeah it doesn't support 2.6.9.89.03, only 2.6.9.89 which is what the problem was. You'd think they support the whole family of that kernel version not just the specific flat version without any .release. But yeah, we either have to re-compile it to our version or go with a kernel version that matches what they want until the errata version is available.

Thanks guys, was just looking to see if there was a better way/shortcut.

Jason
Jason Mecucci
Occasional Advisor

Re: Trouble installing Raid controller drivers on linux on a G6

See above post.