General
cancel
Showing results for 
Search instead for 
Did you mean: 

Try to disable Firewall for testing purpose but failing

sinhass
Regular Advisor

Try to disable Firewall for testing purpose but failing

Hi,
I am trying to change my firewall status of my 2 redhat 8.0 box from high to medium as I want to run pcxware from my win2k PC. But whenever I am trying to do its showing done but not working. I faced same problem for ftp and I did it manually. But I don't know which file to be edited to override default settings. I tried with service iptables stop. tried redhat-config-securitylevel as well as setup command. openssh is running in the boxes.
Thanks in advance
4 REPLIES
Claudio Cilloni
Honored Contributor

Re: Try to disable Firewall for testing purpose but failing

running

# service iptables stop

will flush your iptables rules. verify with this:

# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

If you see this output, then iptables firewall is disabled. So the problem should be elsewhere...

Ciao
Claudio
sinhass
Regular Advisor

Re: Try to disable Firewall for testing purpose but failing

iptables -L output is here
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
Steven E. Protter
Exalted Contributor

Re: Try to disable Firewall for testing purpose but failing

service iptables stop will shut down the firewall.

I suspect that the reason things are not working after that command are that you need the firewall up for your testing.

So, perhaps post the configuration and the details of what you are trying to do and someone can help.

The commands in the prior post are exactly what were required to answer your question as written.

for open ssh testing try ssh -v to get some idea where the problem is happening.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
sinhass
Regular Advisor

Re: Try to disable Firewall for testing purpose but failing

Hi Sep,
Actually I am trying to manage my redhat linux 8.0 boxes remotely with pc-xware. I can manage my sun boxes. But its not allowing me for linux boxes. It is not allowing to ftp/telnet.I suspect that openssh may be the reason behind it. And after editing vsftp file I can ftp it. with Putty everything OK except telnet. But I can ssh this server. the output of scanssh is

192.168.70.231 SSH-1.99-OpenSSH_3.4p1

output of ssh -X -v 192.168.70.231 is
[root@Linux1 ssh]# ssh -v 192.168.70.231
OpenSSH_3.4p1, SSH protocols 1.5/2.0, OpenSSL 0x0090602f
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Rhosts Authentication disabled, originating port will not be trusted.
debug1: ssh_connect: needpriv 0
debug1: Connecting to 192.168.70.231 [192.168.70.231] port 22.
debug1: Connection established.
debug1: identity file /root/.ssh/identity type -1
debug1: identity file /root/.ssh/id_rsa type -1
debug1: identity file /root/.ssh/id_dsa type -1
debug1: Remote protocol version 1.99, remote software version OpenSSH_3.4p1
debug1: match: OpenSSH_3.4p1 pat OpenSSH*
Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_3.4p1
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: dh_gen_key: priv key bits set: 117/256
debug1: bits set: 1593/3191
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
Connection closed by 192.168.70.231
debug1: Calling cleanup 0x80674b0(0x0)