Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

UI Timeout for HP Mgmt page, SLES9

Eric Meiring
Frequent Advisor

UI Timeout for HP Mgmt page, SLES9

Hello,

I'm running SLES9 on an HP DL360, and have the HP support pack and management agents installed. Things were running just fine, and we ended up shipping the server to a remote office and running it from there. In the process, we had to re-IP it.

Now when I try to get to the system management page (https://localhost:2381) I can get it to load, but keep getting an error message indicating that a timeout occurred. Sure enough, in the system mgt log I can see:

"ERROR LOG (severity=2)
UI Timeout -- Nav Load Time: 318s [breakdown: webagent(HP Foundation Agent): 102s.....]"

Anyone have an idea what might be causing this timeout error (the webagent taking so long to load...), and how to fix it? Seems suspicious that it decided to happen once we relocated the server and re-IP'd it.

Thanks much,
Eric
8 REPLIES
sandeep_raman
Honored Contributor

Re: UI Timeout for HP Mgmt page, SLES9

Hello Eric,

Check if this helps:
1.Restart snmpd
2.Restart all hp agents(smhd..)
3.Use the Server DNS name instead.

SRH
Eric Meiring
Frequent Advisor

Re: UI Timeout for HP Mgmt page, SLES9

Hi Sandeep,

I tried your suggestions, but no dice. I even restarted the whole hpasm set of stuff, and it all appears to be running, but I get that error.

I actually used https://[serverIP]:2381 and got the same results, whether the browser was remote (at my desk), or opened up via Mozilla on the server itself.

So I fear the problem is still present. Perhaps a server reboot is in order, although I'm not overly confident that will do it.
sandeep_raman
Honored Contributor

Re: UI Timeout for HP Mgmt page, SLES9

Thats the next thing(reboot) sadly. :(

PS :Whats the PSP version?

SRH
Eric Meiring
Frequent Advisor

Re: UI Timeout for HP Mgmt page, SLES9

I believe it is PSP 7.5. I will try for the reboot and see what happens...
sandeep_raman
Honored Contributor

Re: UI Timeout for HP Mgmt page, SLES9

Holdon,since the error is referring HP Foundation Agent,try restarting its sub-agents:

/opt/compaq/foundation/bin/cmahostd
/opt/compaq/foundation/bin/cmathreshd

PS: Not too sure if it is restarted with other agents.

SRH
Eric Meiring
Frequent Advisor

Re: UI Timeout for HP Mgmt page, SLES9

Well, it looks like cmathreshd and cmahostd do actually start when I start hpasm, and all start automatically when the server boots.

I tried manually restarting all 3, but it didn't help. I even rebooted the server, and still get the problem. I'm at a loss as to what might be the problem at this point.
Eric Meiring
Frequent Advisor

Re: UI Timeout for HP Mgmt page, SLES9

Update - it turns out, I had to set up the SNMP stuff to get the problem to go away. I had not set it up since I was concerned our Windows-dominated environment wasn't equipped to handle SNMP traps from Linux servers yet.

But I'll deal with that later. At this point, I know what the issue is, so that's good. Googling parts of the error message did it for me (an answer was found in another HP forum post here! I should have looked here first).

Thanks all,
Eric
Eric Meiring
Frequent Advisor

Re: UI Timeout for HP Mgmt page, SLES9

See my above post - configuring SNMP traps did the trick!