Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
Showing results for 
Search instead for 
Did you mean: 

USB Key causing hang on DL385

Occasional Visitor

USB Key causing hang on DL385

An interesting problem- when I plug in a USB
key into the USB port on the front of the
DL385, the system hangs. When the key is
plugged into either of the USB ports on the
back, it works fine. Have tried this with
two different keys from different manufacturers.

Am running RedHat Enterprise Linux 4.0 Update 3, on a dual processor DL385 with 9GB of memory.

Has anyone seen this?

Steven E. Protter
Exalted Contributor

Re: USB Key causing hang on DL385


Its a bad USB port.

Put in a hardware call, but they'll probably have to replace the entire system board.

Steven E Protter
Owner of ISN Corporation
Occasional Visitor

Re: USB Key causing hang on DL385

Sorry, forgot to mention that the same
hang occurred (when a USB key was plugged
into the front port) on 2 different DL385s,
while the back port worked fine on both.

Sorry for the missing info, and thanks for
the reply.

Paul Hansen
Honored Contributor

Re: USB Key causing hang on DL385

I've never had any luck using the front panel usb for anything but storage. On some HP boxes, there is a dedicated usb port (on the back) for keyboard/mouse operations.

I would recommend downloading and installing the latest system firmware.
Bill Thorsteinson
Honored Contributor

Re: USB Key causing hang on DL385

Check the output of dmesg after booting.
You will likely see two different USB types,
and possibly speeds. The driver for the
USB on the front is not handling the USB
port correctly.

One of the drivers has two different versions,
you may want to try loading the other version.
Occasional Visitor

Re: USB Key causing hang on DL385

From what I can see looking at dmesg and
lspci output, there are in fact two ohc
usb1.1 controllers on the AMD-8111 I/O hub.
There's also an ehc controller according
to the spec sheet, but the DL385 doesn't use

Dmesg shows both of the ohc's being init'ed
ohci_hcd: 2004 Feb 02 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
ohci_hcd 0000:01:00.0: OHCI Host Controller
ohci_hcd 0000:01:00.0: irq 161, pci mem f881c000
ohci_hcd 0000:01:00.0: new USB bus registered, assigned bus number 1
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 3 ports detected
ohci_hcd 0000:01:00.1: OHCI Host Controller
ohci_hcd 0000:01:00.1: irq 161, pci mem f881e000
ohci_hcd 0000:01:00.1: new USB bus registered, assigned bus number 2
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 3 ports detected

and an lsmod shows the ohci_hcd driver
loaded. Everything seems to be fine.
One system has a USB interface to an APC
ups, one doesn't.

Could this be a firmware issue? We're
using the A05 6/14/2005 version.