Showing results for 
Search instead for 
Did you mean: 

Re: USB Storage, SLES8 and Booting...

Trusted Contributor

USB Storage, SLES8 and Booting...

Hello all,

I have an interesting problem. I have a SuSE Enterprise Linux running on a 2.4 kernel.

I'm trying to create an init script that will mount a USB key-disk and run a script on there. The point of this is that having invoked DR last week, building servers takes too long, so we're putting together a ghost image we can quickly restore and the key-disk will contain the IP Addresses and Hostnames of systems to allow us to effectively recover a system in much reduced time.

Anyway, the mount command on our box is below:
/bin/mount -t vfat /dev/sda1 /mnt

However, when I try this as an init script in the boot.d directory (it's S11 in boot.d) I get the following error:

Can't locate module block-major-8

This works when the system is fully loaded, and I've made a dependency on boot.ldconfig, but to no avail. I've also tried adding modprobe usb-storage and modprobe vfat in the start-up script, with no difference.

Does anyone know what I need to load to get this working? I'm not that good with modprobe and linux modules, but need to get this working asap!

Thanks for you help guys!
Valued Contributor

Re: USB Storage, SLES8 and Booting...

hi michael,

the problem is that you will need to load the usb-drivers/diskdrivers. could you post a bit more about your hardware (usb-chip, external harddisk, usb-diskdriver, ...) try to run a lsmod and post it's output so that we can see what modules your linux is using in normal operation with attached and mounted usb-disk.

best regards,

"First off, I'd suggest printing out a copy of the GNU coding standards, and NOT read it. Burn them, it's a great symbolic gesture." (Linus Torvalds)
Trusted Contributor

Re: USB Storage, SLES8 and Booting...

I think Johannes is correct. I ran into a somewhat analogous problem on one of my systems after upgrading from a distribution with a 2.4 kernel to a distribution with a 2.6 kernel because the module names changed. I tried modprobe usb-storage and several other module combinations. The 'block device' errors finally went away when I did modprobe for the usb controller. There are drivers for several different controllers, so you'll need to figure out which controller your hardware has.

Trusted Contributor

Re: USB Storage, SLES8 and Booting...

Hi Michael,
on my 2.6.4-52-default kernel form SuSe Proffesional I have to load usb_storage modul

and AFTER THAT instert usb key into port,
in other case I'm getting
mount: special device /dev/sdb1 does not exist

I know it isn't solving your problem, but maybe
it will help you in finding solution

br Jan
GSM, Intelligent Networks, UNIX
Trusted Contributor

Re: USB Storage, SLES8 and Booting...

Yet another thing

check whether scsi emulation modul is loaded

full path on my box is:

br Jan
GSM, Intelligent Networks, UNIX