General
cancel
Showing results for 
Search instead for 
Did you mean: 

USB flash drive problem with Red Hat 8.0

pierre gauthier
Occasional Contributor

USB flash drive problem with Red Hat 8.0

I have successfully mounted a USB
flash drive (128 Mb) on my Red Hat
8.0 system (HP XW4100 workstation).
I can read and write files no problem.
If I umount the drive and mount it again,
it doesn't work and I get a "No medium found"
message after mounting. I have to reboot
the workstation to be able to mount the USB drive again.

Any idea about what could be causing this
problem? Is there another step after
unmounting the drive that I'm missing?


#this works and I can read/write files
mount -t auto /dev/sdc /some_directory

#this seems OK
#umount /somedirectory

# I disconnect the drive and connect it again
# mount -t auto /dev/sdc /somedirectory
No medium found
4 REPLIES
Alexander Chuzhoy
Honored Contributor

Re: USB flash drive problem with Red Hat 8.0

Try to check your log files:
/var/log/messages
and
dmesg
for errors
Tom Geudens
Honored Contributor

Re: USB flash drive problem with Red Hat 8.0

Hi,
Turn on USB logging/debugging (if you're allowed to recompile the kernel). I've had a LOT of problems in getting an USB harddrive to work with Red Hat 8.0 (although it works flawlessly with RH 9.0) and those loggings were very helpfull.

Regards,
Tom Geudens
A life ? Cool ! Where can I download one of those from ?
Dave Falloon
Trusted Contributor

Re: USB flash drive problem with Red Hat 8.0

Are you using kernel modules or is usb built in to the kernel directly?

lsmod will tell you whether you are using a module or not. Perhaps what is happening is the module stays loaded after you have unmounted the drive and when you connect a second time it doesn't pick it up or something to that effect. It may be worth it to try removing the module ( if you are using modules ) after you unmount and then see if you can plug it back in and have it work.

It may be a long shot but it can't hurt to try.

Dave
Clothes make the man, Naked people have little to no effect on society
pierre gauthier
Occasional Contributor

Re: USB flash drive problem with Red Hat 8.0

Using lsmod shows that the usb-storage module
gets loaded after I insert a usb flash
drive (I verified this module was not
loaded before).

After umount, this module is still
loaded. I removed it with rmmod and inserted
the usb drive. But the usb-storage module
does not load automatically. If I load
it manually (insmod), I still cannot
load my usb flash drive.