cancel
Showing results for 
Search instead for 
Did you mean: 

Umask Seting

Origin Energy
Occasional Contributor

Umask Seting

Hi

OS HPUX 11.31
Default umask is 022 for root
if we create a file by using touch command then we are not getting the excute permission for that file.

Can any one help on this.

bash-3.2# touch xml
bash-3.2# ls -l xml
-rw-r--r-- 1 root sys 0 Aug 26 15:33 xml


Regards
Origin energy
5 REPLIES
Shan Sunny
Occasional Advisor

Re: Umask Seting

Hi,
This is normal.
For Files Effective permission= 666-022 = 644 (-rw-r--r--)
For Directories Effective permission = 777-022 = 755 (drwxr-xr-x)

Your points are appreciated.

Regards,
Shan.
avizen9
Esteemed Contributor

Re: Umask Seting

its correct settings

after you create file with touch command you need to use chmod +x
Dennis Handly
Acclaimed Contributor

Re: Umask Seting

>avizen9: after you create file with touch you need to use chmod +x

More realistically, after you create your script with your favorite editor, then you use chmod(1).
Lijeesh N G_1
Respected Contributor

Re: Umask Seting

Hi,

HP-UX will not assign execute permission to a file by default, in case of a directory it will.

it is normal..

Regards,
LIJEESH N G
Lijeesh N G_1
Respected Contributor

Re: Umask Seting

Hi,

You can change the permission with chmod command,

check the man page of chmod for more details by,
#man chmod

or refer below link,

http://nixdoc.net/man-pages/HP-UX/chmod.1.html

Regards,
LIJEESH N G