Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to connect to OEM by sys as sysdba

SOLVED
Go to solution
V.Tamilvanan
Honored Contributor

Unable to connect to OEM by sys as sysdba

Hi all,
Recently i have created manually an oracle 9i database.I am able to connect to sqlplus as sys (as sysdba). But I couldn't through the gui oemapp dbastudio OEM.
I could able to connect as system to OEM but not as sys.
Can somebody throw some light on this.

TIA.
7 REPLIES
Alexander M. Ermes
Honored Contributor

Re: Unable to connect to OEM by sys as sysdba

Hi there.
Default user for Oracle Enterprise Manager is SYSMAN.
Default password is oem_temp.
Try to run OEM console.
If it works, it should ask you for new password.
Rgds
Alexander M. Ermes
.. and all these memories are going to vanish like tears in the rain! final words from Rutger Hauer in "Blade Runner"
V.Tamilvanan
Honored Contributor

Re: Unable to connect to OEM by sys as sysdba

Hi Alexander,
We don't have any oracle management server. I am trying to connect to the local oracle server only as sys.
I am able to connect through sqlplus the same with the same password.

Pls. help me to connect to the gui as sys.

TIA.
Massimo Bianchi
Honored Contributor
Solution

Re: Unable to connect to OEM by sys as sysdba

Hi Tamil,
which string do you use for connecting and which OEM are you using, the one that comes with the 9i or an older one ?

From your PC, are you able to connct to the oracledb?

Fron the CLI, can you connect as "sys@SID as sysdba" ?
I suspect that some grants are missing, like sysdba, and the remote_login_password_file is set to public and not to exclusive.

After setting the parameter to exclusive, rememebr to creare the password file with the command orapw.

Massimo
Indira Aramandla
Honored Contributor

Re: Unable to connect to OEM by sys as sysdba

Hi Tamil,

When logging into the OEM Console application, leave the default as "Connect as NORMAL". The SYSDBA or SYSOPER privileges can be set for each database from within the OEM console.

If you need to logon as SYSDBA, set the Preferred Credentials from within the OEM Console.

To set these privileges:

1. Select FILE->PREFERENCES from within the OEM Console.
2. Highlight the database and change the role from NORMAL to either SYSDBA or SYSOPER.
3. Click APPLY.

The next time you attempt to connect from the OEM applications, the application will connect as the role you selected.

Note: Before the SYSDBA role can be granted to a user, the init.ora file must have the parameter "REMOTE_LOGIN_PASSWORDFILE=EXCLUSIVE.


I hope this helps.
Never give up, Keep Trying
Yogeeraj_1
Honored Contributor

Re: Unable to connect to OEM by sys as sysdba

hi TIA,

You need to grant the sysdba role to the user.

Note that, by default the internal user has the sysdba privilege. The system and sys do not.

hope this helps!
regards
Yogeeraj
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
V.Tamilvanan
Honored Contributor

Re: Unable to connect to OEM by sys as sysdba

Hi All,

Thanks for all the replies. Right now the parameter REMOTE_LOGIN_PASSWORDFILE=NONE is set in my init.ora file. So the authentication is done by the OS. But we cannot login as sys through gui if we set OS authentication.
As Massimo and indira told if I set
REMOTE_LOGIN_PASSWORDFILE=exclusive I should be able to connect as user sys as sysdba through gui.

Thanks.
T G Manikandan
Honored Contributor

Re: Unable to connect to OEM by sys as sysdba

yes,
It should be

REMOTE_LOGIN_PASSWORDFILE=exclusive
to login from DBA studio


That should resolve the problem.

Also query your v$pwfile_users

check whether the user has the sysdba privilege.

Thanks