General
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to see luns beyond 0 with Emulex LP9002L and VA7410

SOLVED
Go to solution
Carlos Martinez Juarez
Occasional Visitor

Unable to see luns beyond 0 with Emulex LP9002L and VA7410

Hi:
I'm running a RedHat Advanced Server 2.1 on a proliant DL380 G3, with an HP Virtual Array VA7410, and an Emulex LP9002L Fiber Channel Card.
We are unable to see luns beyond 0 (and I'm absolutely sure I've defined more than one lun on my VA).
We have installed Emulex drivers, recompiled kernel (with Probe all luns on each SCSI device), we have passed "max_scsi_luns=X" through lilo (where X is greater than 1).
Any clues to see more luns?
Thanks in advance ;-)
4 REPLIES
Kodjo Agbenu
Honored Contributor
Solution

Re: Unable to see luns beyond 0 with Emulex LP9002L and VA7410

Hi,

You should consider recompiling the kernel with the option CONFIG_SCSI_MULTI_LUN set.


Additional issue : if you have gaps in LUN numbering, you also need to recompile the kernel after having modified the scsi driver as follows :

/usr/src/linux/drivers/scsi/scsi_scan.c

...
...
{"HP", "A6188", "*", BLIST_SPARSELUN}, // HP VA7100
{"HP", "A6189", "*", BLIST_SPARSELUN}, // HP VA7400
{"HP", "A6218", "*", BLIST_SPARSELUN}, // HP VA7410
{"HP", "OPEN-", "*", BLIST_SPARSELUN}, // HP XP



Good luck.

Kodjo
Learn and explain...
Dineshkumar Surpur
Frequent Advisor

Re: Unable to see luns beyond 0 with Emulex LP9002L and VA7410

You could also change parameters in Emulex driver lpfc.conf.c to get sparse luns

Ex:

int lpfc_lun0_missing=1;
int lpfc_lun_skip=1;

and rebuild the Emulex driver and ramdisk image.
-------------------

I was told that Compaq Storage Array does not need the setting "Probe all luns on each SCSI device" it is true ? and if it is then do the compaq storage arrays present luns as different targets to the Emulex host HBA driver ? does anybody know on this.
Carlos Martinez Juarez
Occasional Visitor

Re: Unable to see luns beyond 0 with Emulex LP9002L and VA7410

All what you say is true but not before installing RedHat Errata latest kernel and patches. Then rebuild kernel with CONFIG_SCSI_MULTI_LUN set.
Carlos Martinez Juarez
Occasional Visitor

Re: Unable to see luns beyond 0 with Emulex LP9002L and VA7410

Install latest patches and use parameters related before