Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to start service "xfs".

Rajesh SB
Esteemed Contributor

Unable to start service "xfs".

Hi Experts,

I am not able to start X-Window.
I have a problem in starting xfs daemon.
If try to start
# service xfs start -- Saying [OK]
When u check status
# service xfs status -- Saying xfs service dead.

When I start xfs explicitly, running.

# nohup /ust/bin/xfs &
Then I am able to run/work on X.

I am using RedHat 7.2 Linux.

Any pointer for this. How to fix/check error this problem.

Thanks in advance,

Cheers,
Rajesh
3 REPLIES
Ralf Puchner
Honored Contributor

Re: Unable to start service "xfs".

xfs is only the font server, this server is only necessary if there is no path to local font directories. Use the xset -q command to check the font path (this does only work if the X11 server is still running).


Help() { FirstReadManual(urgently); Go_to_it;; }
Jerome Henry
Honored Contributor

Re: Unable to start service "xfs".

Usually, this service crashes when it doesn't find required fonts.
Try this to check first available space on root partition (/). If it's too short, the xserver can't load xfonts.
Check then if this prob only occurs when you startx as root (which may be normal under certain circumstances, I'll explain you which if it's the case), or if it's the same when you log in as an user.
Last, post the exact message you get on starting X if the above tips didn't help.
RGDS

Jerome
You can lean only on what resists you...
Stuart Browne
Honored Contributor

Re: Unable to start service "xfs".

The /etc/init.d/xfs routine on RedHat does a number of things before it actually starts XFS (with the flags -droppriv and -daemon).

It requires the use of a number of commands (such as 'chkfontpath', 'mkfontdir' and 'ttmkfdir'), but most of all it needs access to the /usr/X11R6/lib/fonts/ directory structure.

You've not said what user you are using when trying to start xfs, but given the command you issued, I'll assume it's root.

Thinks to look at.

If you've not modified the XFS config file, XFS will create a socket-file in the /tmp/.font-unix/ structure called "fs7100" (where 7100 is the port number specified in /etc/X11/fs/config).

It should appear with permissions 777, and be a socket (permissions look like: srwxrwxrwx). If this isn't created successfully, or another process is using the socket file, then it would start anyway (with those flags atleast).

In all honesty, the only reason I can see that 'service xfs start' wouldn't start the font server is if /usr/X11R6/bin/X wasn't a symbolic link.

Have you manually changed any of the settings in /etc/X11/fs/config ?
One long-haired git at your service...