Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

Unsatisfied symbols whilst trying to relink Oracle Web Server 3.0.2

Steve Bruce_2
Occasional Visitor

Unsatisfied symbols whilst trying to relink Oracle Web Server 3.0.2

Hi

Trying to relink OWS 3.0.2 on HPUX 11.00 on an N4000, after applying the HWE 1100 patch bundle. Application won't work after applying bundle.

We need to apply patch bundle so that can use ignite tape to build new RP2470 server in image
of N class.

Using Oracle recommended makefile and instructions. Receive error message.....

cc -Wl,-aarchive_shared,+s,-E,-Bimmediate -o logperf -L/u01/app/oracle/p
roduct/2.1/ows/3.0.2/lib -L/u01/app/oracle/product/2.1/lib ndwzap.o /u01/app/ora
cle/product/2.1/ows/3.0.2/lib/liblogmgr.a /u01/app/oracle/product/2.1/ows/3.0.2/
lib/libndwad.a /u01/app/oracle/product/2.1/ows/3.0.2/lib/libndw1.a -lsqlnet -ln
cr -lsqlnet -lclient -lcommon -lgeneric -lsqlnet -lncr -lsqlnet -lclient -lcommo
n -lgeneric -lepc -lnlsrtl3 -lc3v6 -lcore3 -lnlsrtl3 -lcore3 -lnlsrtl3 `ca
t /u01/app/oracle/product/2.1/rdbms/lib/sysliblist` -lcma -ldld -l:libc.sl -l
:libm.sl `cat /u01/app/oracle/product/2.1/rdbms/lib/sysliblist` -lC
/usr/ccs/bin/ld: Unsatisfied symbols:
__ConstructArray__FPvUiUlPFv_vT4 (code)
__DestructArray__FPvUiUlPFv_v (code)
__nwa__FUl (code)
*** Error exit code 1
Stuck here working late again
1 REPLY
Paul Hawkins
Frequent Advisor

Re: Unsatisfied symbols whilst trying to relink Oracle Web Server 3.0.2

Hi, yes we had a very similar problem...
The way we got around it was to copy the original library files into a new area /usr/oldlibs . We then "chatr" d the oracle binaries to enable for shared-libraries and altered the shlib_path.
This, along with removing the logperf entry in the makefile seemed to fix the problem.

Hope this helps ;-)
Paul