General
cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrade from Oracle 7.3.4 to Oracle 8.1.6: libraries to be linked for Pro*C

SURESH_5
Occasional Visitor

Upgrade from Oracle 7.3.4 to Oracle 8.1.6: libraries to be linked for Pro*C

Hi,

We are upgrading our database from Oracle 7.3.4 to Oracle 8.1.6 (OS: HPUnix11)
We are trying to recompile, link and run C (Pro*C) applications

Somehow succeeded to compile but when run they give Bus error(coredump)

I think that proper libraries are not linked in the correct order

The libraries linked currently in the makefile are

In Oracle 8.1.6 linked libraries
PROLDLIBS= -L$(ORACLE_HOME)/lib `[ -f $(ORACLE_HOME)/lib/libxa.a ] && echo -lxa` -lsql8 -lclntsh -lclntsh $(ORACLE_HOME)/lib/libclient8.a $(ORACLE_HOME)/lib/libcommon8.a -lgeneric8 -lclntsh -lclntsh $(ORACLE_HOME)/lib/libclient8.a $(ORACLE_HOME)/lib/libcommon8.a -lgeneric8 -lnl8 -lcore8 `cat $(ORACLE_HOME)/lib/sysliblist` -lm -lcma

In previous makefile(Oracle 7.3.4) linked libraries
PROLDLIBS= -L$(ORACLE_HOME)/lib `[ -f $(ORACLE_HOME)/lib/libxa.a ] && echo -lxa` -lsql -lsqlnet -lncr -lsqlnet $(ORACLE_HOME)/lib/libclient.a $(ORACLE_HOME)/lib/libcommon.a -lgeneric -lsqlnet -lncr -lsqlnet $(ORACLE_HOME)/lib/libclient.a $(ORACLE_HOME)/lib/libcommon.a -lgeneric -lepc -lnlsrtl3 -lc3v6 -lcore3 -lnlsrtl3 -lcore3 -lnlsrtl3 `cat $(ORACLE_HOME)/rdbms/lib/sysliblist` -lm

Any idea what all libraries have to be linked and their order on Oracle 8.1.6

Thank You
2 REPLIES
A. Clay Stephenson
Acclaimed Contributor

Re: Upgrade from Oracle 7.3.4 to Oracle 8.1.6: libraries to be linked for Pro*C

Before I would even look at linking problems, I would use the debugger to get a stack trace to determine the underlying problem. It could be bad code that was working by accident on the older platform. I've actually seen several examples of that.
If it ain't broke, I can fix that.
SURESH_5
Occasional Visitor

Re: Upgrade from Oracle 7.3.4 to Oracle 8.1.6: libraries to be linked for Pro*C

Hi

Thanks for ur info.

I tried to debug the program. The program does not even print the first statement. Below is the debug info.

Any idea what the problem might be.

Thank you



Program received signal SIGBUS, Bus error.

[Switching to thread 1 (user thread (1417, 0))]

0x7ae325a0 in pthread_mutex_init () from /usr/lib/libpthread.1

(gdb) backtrace

#0 0x7ae325a0 in pthread_mutex_init () from /usr/lib/libpthread.1

#1 0x7b02389c in libc_init () from /usr/lib/libc.2

#2 0x7b023000 in __libc_init () from /usr/lib/libc.2

#3 0x7aedfe9c in hp__pre_init_libc () from /usr/lib/libcma.2