cancel
Showing results for 
Search instead for 
Did you mean: 

User login in Linux

SOLVED
Go to solution
Samuel Mathew
Frequent Advisor

User login in Linux

This is probably a basic question. I have a user that is defined as a NIS user. When I try to login the message comes, "Your session only lasted less than 10 seconds. If you have not logged out yourself, this mean that there is an installation problem or that yo umay be out of diskspace. Try logging in with one of the failsafe sessions...". What is a quick fix for this? Obviously there is a problem in the ,.profile or .Xdefaults. can you please guide me in this?
Regards
19 REPLIES
Dan Beeler_2
Occasional Advisor

Re: User login in Linux

I found this at the website listed below...hope it helps.

Try this boot your linux with the RH9.0, and during the installation choose something like 'system update' to update your system. after update, do the RH upgrade again with your Xwindows.

http://www.experts-exchange.com/Operating_Systems/Linux/Linux_Administration/Q_20695627.html#9062544

I would try editing the /etc/inittab to have a default run level of 3. This would allow you to make any changes and then you can try your X environment by running startx.

Hope this helps.

--dan
Paulo A G Fessel
Trusted Contributor

Re: User login in Linux

Have you configured all neccessary fields on your NIS server for this user?

Try to log that user on using text mode (just use Ctrl+Alt+F1). Does these messages appear?

root@wotan's password:
Last login: Mon Sep 1 17:57:46 2003
Could not chdir to home directory /rooto: No such file or directory
/usr/X11R6/bin/xauth: error in locking authority file /rooto/.Xauthority

If something like this appears, then you haven't populated your NIS database correctly. I don't have a NIS machine available now, but you can use "ypcat" commands to check up all the fields of your NIS server.

HTH
Paulo Fessel
L'employé propose, le boss dispose.
Samuel Mathew
Frequent Advisor

Re: User login in Linux

Thanks for the replies. It doesn't solve my problem fully. The NIS server is an HP -UX machine running 10.20.
I did define my windows correctly using the xterm command and putting it in .profile for that user. But I cannot get a desktop user login field back if I exit from this user. How do I set up a desktop for a user in Linux?
I would appreciate a url or a write up that can be pasted here.
Appreciate the help
Regards
Paulo A G Fessel
Trusted Contributor

Re: User login in Linux

Sorry, but I don't understand what you mean.

Could you copy the screens and attach them to this topic?

Also, as I understand your problem is not X related, but it's NIS related. For example, the NIS points to the correct home directory of the user? Can you access the home directory of this user when you log on?

Also, normally it's neccessary NFS-mount the /home from a server, which can be the NIS master server itself or another machine which is a memeber of the NIS realm that exports /home to the machines to the domain.

[]'s
Paulo Fessel
L'employé propose, le boss dispose.
Alexander Chuzhoy
Honored Contributor

Re: User login in Linux

I think that you problem is that your nfs user doesn't have his home directory automatically mounted on NIS server...

Generally you need to share via NFS /home directory on NIS server and on client machines
to enable the autofs service.
The syntax for /etc/auto.misc is the following:
* -intr,soft,rw,rsize=8192,wsize=8192 NIS server's IP or hostname:/home/&
on one line of course...
Dave Falloon
Trusted Contributor

Re: User login in Linux

I would recommend against a soft mount when using autofs over UDP with linux. There is a potential for lost data. Check out the linux NFS faq for more info:

http://nfs.sourceforge.net/#section_e

I had this problem with an HP-UX machine exporting to linux as well. I fixed it with proto=tcp in the autofs auto.master and it seems to work a lot better. You will need to have a kernel that supports NFS over TCP and as far as I know it is still listed as experimental although I have used it for months.

I hope that helps,

Dave
Clothes make the man, Naked people have little to no effect on society
Vitaly Karasik_1
Honored Contributor

Re: User login in Linux

1) does "su - username" work OK?

2) does non-graphic (telnet) login work?


If no, please send us error messages you receive.

Rgds,
vitaly
Samuel Mathew
Frequent Advisor

Re: User login in Linux

Thanks for the several answers. My replies are as below:
Dan Beeler: I can't upgrade to Red Hat 9.0 now. The X environment is starting up. I get the login screen. I can switch between text and gui with Alt-Fn keys.
Paulo Fessel: I don't get that error. When I log in as a user samm, I get a window that says, "Your session only lasted less than 10 seconds. If you have not logged out yourself, this could mean that there is some installation problem or you may be out of diskspace. Try logging in with one of the failsafe sessions to see if you can fix this problem" View details (~/.xsession-errors file)."
I looked at that file, it says.
"tset: standard error: Inappropriate ioctl for device

stty: standard input: Inappropriate ioctl for device
stty: standard input: Inappropriate ioctl for device
/usr/bin/ksh: L????????[0]: tabs: not found
_X11TransSocketINETConnect: Can't get address for cyber

(gnome-session:3291): Gtk-WARNING **: cannot open display:logout"

Does this make sense? I hope you can get me some answer to what is happening..( I can access the home directory of this user as I can log on from a character terminal cntl-Alt-F1 login). The /home is automatically mounted automatically because of the entry in /etc/fstab. I have put the line there as
10.3.69.200:/home /home nfs defaults 0 0.
I don't have an automount entry. I anyway entered the auto.misc that Alexander suggested.No improvement....
Vitaly Karasik: su - username works in character mode. telnet login works fine too.
By the way I can login as root using the x environment and it shows the icons correctly. So what should I do get the other users (who are all nis users) to do the same thing. Again NIS server is HP-UX 10.2 and the clients are Linux.
Thanks for all the help.
Regards

My presumption: It is something to do with configuring the x envirornment of the user. I am not sure though.. I am novice to x environment
Vitaly Karasik_1
Honored Contributor

Re: User login in Linux

1) when NIS user login by telnet, does he get his homedir?

1.1) does NIS user have write permission for his homedir?

2) try to delete all .???* files from some_user homedir and try to login
Samuel Mathew
Frequent Advisor

Re: User login in Linux

Vitally and other friends.
Thanks for the help till now, but it is not yet over...,
Yes, I can do a telnet and it goes the user's home directory. Eg. /home/samm.
Yes full permission to the home directory.
I deleted the .prof* files and then logged in through character. But now through the xwindow login, it doesn't go beyond the blank screen that comes after you enter the user name. So it seems to me that it is not having the xwindows initialisation files there... Am I right? Esp. since root logs in fine there. Now as I told you I have /home on a nfs mounted directory which is on a HP-UX. So when this user logs in on a linux machine I need to load the linux x window files. How do I do that? Or do you see another problem here?.
I think we are getting there.. slowly. I think if you can guide me to set up a user (not local but NIS user) on linux considering the fact that the NIS database is on HP-UX is the clue, I guess.
Thanks for the help.
Paulo A G Fessel
Trusted Contributor

Re: User login in Linux

Ok, I see it now.

Do you have Gnome running on your HP-UX server? Do users log in directly onto that server?

Also, perhaps the data files generated by Gnome at HP-UX in a native HP-UX logon may be incompatible with those of Linux. For example, AFAIK PA-RISC is big-endian while Intel is low-endian, and thus binary files may be incompatible between versions.

Maybe it will be neccessary to check where your user is logging in your xinitrc script, and then set directories accordingly, creating one directory for HP-UX data and other for Linux data.

HTH
Paulo Fessel
L'employé propose, le boss dispose.
Samuel Mathew
Frequent Advisor

Re: User login in Linux

Ooh!. That went over my head....
Gnome is supposed to be running on HP Server? Because it is NIS server and Linux clients are there? That makes sense. Now how do I start that on HP-UX. I didn't ever envisage this to happen.
If you could explain to me the setting of the directories etc.. could have been very helpful.
Where do I look for xinitirc script and how it all interplay?
Well, I hope I can get some help this time..to move forward. It all makes sense
Sam
Paulo A G Fessel
Trusted Contributor

Re: User login in Linux

No, Gnome doesn't need to be runing at HP-UX side. What I asked was if this user logs onto this HP-UX server and starts an X session there with Gnome, redirecting X output for his/her terminal.

If this happens, then it's possible that there's an .Xsession file on his/her home directory that refers actually to a X session started in HP-UX and not in Linux, and thus may not be compatible with your linux clients.

So, check if there is one (or more) of these files in user's home directory:

* .xsession
* .Xclients
* .xinitrc
* any .X* file with permissions such as 700 (minimum)

If it's the case, so you'll need to rewrite one of them to know whether you're connecting from Linux or HP-UX (an "uname -s" should take care of this). Based on this you could do a symlink to ~user/.gnome from one of two directories (e.g.: .gnome-Linux and .gnome-HP-UX) and them initiate the startup of X environment.

To be sure of this, try to rename the existing ~user/.gnome and ~user/.gnomerc files/directories. What does it happen?

(I don't use Gnome as I prefer KDE, but the way of storing local settings is pretty the same.)

HTH
Paulo Fessel
L'employé propose, le boss dispose.
Vitaly Karasik_1
Honored Contributor

Re: User login in Linux

try two things

1) I suggest just delete ALL dot-files from user home directory


2) try to change NIS-user homedir to local dir.
Samuel Mathew
Frequent Advisor

Re: User login in Linux

Thanks for the inputs. I found that if I create a home directory on the local drive, I am able to get in. But since this is a NIS environment, I need to have my home directory on the NIS server due to different reasons. Can anybody guide me as to how I can keep the /home/user directory on the NIS server and login and set up my GNOME desktop on the linux box. As I said earlier, my NIS server is a HP UX 10.20
HOpe to hear from you
Regards
Dave Falloon
Trusted Contributor

Re: User login in Linux

On this machine what does the /etc/nsswitch.conf say? Can you attach it to a post.

One the linux machine from the text terminal, login as the user, is there any error messages?

I had trouble with NIS on linux when it was served from a FreeBSD box, specifically because the linux boxes were setup to use shadow passwords and the FreeBSD box was not exporting a shadow map in addition to the regular passwd map. Another problem I ran into with this is that your linux machine will not look for the shadow map at all unless there is an 'x' in the passwd map, anything else will make the client assume that the character is the hashed passwd.

Things you may need to do on your client depending on the OS and whatnot:

- edit the nsswitch.conf so that the client looks to nis first for passwd, hosts, automount, shadow, etc

- Move your /etc/auto.* files to /etc/auto.*.old so that they do now override your NIS files ( can also be accomplished with nsswitch.conf )

- I had to add +:::::: to /etc/passwd and +::: to /etc/group for a few older slackware boxes I have kept around for testing, you may have to do the same

- Make sure that the client machine can nfs mount the directory with the options found in the nis auto.master

- Make sure that the user is in the nis passwd file, ie ypcat passwd|grep user

- do the same for the shadow map

- Make sure the user can change their password, the error can give you clues as to whats wrong.


Here are some more problems I had when I had to set this up:

- I forgot to add the client machine into the netgroup that was allowed to mount the nfs drive

- Automount would not mount over a directory that had anything in it

- The rsize, wsize had to be increased, this was just for performance though

- I had to change from soft mounts to hard mounts after reading the NFS faq

I hope that helps,

Dave
Clothes make the man, Naked people have little to no effect on society
Dave Falloon
Trusted Contributor

Re: User login in Linux

I just reread what you had said earlier, if you can login just fine at the text term, then this definately is an X issue. What does this user try to automatically start when they log in?

After taking another look at your post with the xsession-errors I think the problem is related to this line:

could not get address for cyber

Is cyber a machine on your network?
Check your hosts file and all of the users login files for cyber, ie.

grep -r cyber /home//

I hope that helps,

Dave
Clothes make the man, Naked people have little to no effect on society
Samuel Mathew
Frequent Advisor

Re: User login in Linux

Dave,
I am going to try that. Thanks for the input. At least I have different strings to try,.
I have another problem.I had logged in and opened a gnome-terminal. IN the properties, I changed it to run a command, and the command was a 'cd' command. Because of that, the terminal doesn't come up anymore. It comes up and then closes. Any way of resetting the gnome-terminal properties, so that it will open as earlier. A quick response will be appreciated.
Regards
Sam
David Otero
Occasional Visitor
Solution

Re: User login in Linux

We had the same problem. We have found that setting the following environment variable solved the problem.

setenv GCONF_LOCAL_LOCKS 1