Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

VMunix table full error

Kiran_27
Advisor

VMunix table full error

Hi,

Currently I am getting an error messages in the syslog .
"vmunix: file: table is full "
Can you advice on what should be done ?
We are using a HP-UX B.11.11 U 9000/800 superdome machine .

Moreover I could see that oracle is automatically shutting down. Does this has anything to do with Vmunix table ?

Regards
Kiran
9 REPLIES
Naveej.K.A
Honored Contributor

Re: VMunix table full error

Hi Kiran,

You have exceeded the limit for the maximum number of files which can be opened at time which is controlled by the kernel parameter, NFILE.

You have to modify this kernel parameter either through SAM or command mode and reboot the machine to avoid getting this error message in the future.

This could be one probable reason why your oracle database is shutting down automatically

Regards,
Naveej
practice makes a man perfect!!!
Isralyn Manalac_1
Regular Advisor

Re: VMunix table full error

You have reached the maximum value of the kernel parameter nfile. Since you already have Oracle shutting down, you might want to check the output of "sar -v 1 1". Look for the file-sz column. Check whether the left side is almost the same as the value in the right. If you need to increase the value of nfile, you can do so via kmtune or SAM. Either way, you need to reboot the machine to have this change effected.

Regards,

isralyn
Sudeesh
Respected Contributor

Re: VMunix table full error

I agree with others....
U need to modify the nfile kernel parameter.


Sudeesh
The most predictable thing in life is its unpredictability
Joseph Loo
Honored Contributor

Re: VMunix table full error

hi kiran,

nfile needs to be increase as the rest has mentioned.

which version of Oracle r u using? what is the current nfile value?

regards.
what you do not see does not mean you should not believe
Kiran_27
Advisor

Re: VMunix table full error

The Version of Oracle is 9.2.0.5.0.
The current value of nfile is 13627
nfile 13627 13627 Static N/A Max Number of Open Files
Regards
Kiran
Kiran_27
Advisor

Re: VMunix table full error

Dear Isralyn,

The output of the sar command gave the following values
# sar -v 1 1

HP-UX B.11.11 U 9000/800 05/04/05

11:59:04 text-sz ov proc-sz ov inod-sz ov file-sz ov
11:59:05 N/A N/A 359/8192 0 2844/8424 0 8173/13637 0

Can is your suggestions on the above output .

Regards
Kiran
Naveej.K.A
Honored Contributor

Re: VMunix table full error

Kiran,

Please have a look at the man pages for nfile before doing the modifications.

http://docs.hp.com/en/B2355-60103/nfile.5.html

I think you can increase to 16384 and do a close watch on how the system is performing.

Regards,
Naveej
practice makes a man perfect!!!
Joseph Loo
Honored Contributor

Re: VMunix table full error

hi,

As stated in Oracle Metalink, the recommended nfile for Oracle 9.2.0 is:

NFILE=(15*NPROC+2048)
where NPROC=4096

thus, 16327 is low.

regards.
what you do not see does not mean you should not believe
Florian Heigl (new acc)
Honored Contributor

Re: VMunix table full error

'maxfiles' also has to be raised, I think. It sets the per user-limit for open files.

the oracle shutdown could easily be caused by that, oracle has no other choice in that situation short of dropping user sessions.
yesterday I stood at the edge. Today I'm one step ahead.