General
cancel
Showing results for 
Search instead for 
Did you mean: 

VNC font path on some HP-UX 10.20

error1
Occasional Advisor

VNC font path on some HP-UX 10.20

Hi,
I'm a test engineer and i need to do some modifications on rmb programs on remote site on this 'oldtimers'
can export display to me from all machines, but will be more usefull have vnc on my target ws for my mods.
I have downloaded binaries Vnc and works perfectly on server 10.20
The other 5 ws 10.20 in private network connected to server
and i think server is nfs server
when i installed openssh on server on all other machines was already installed ssh and ssl,
i added only whats missing (libz.sl, sshd user)


Here my problem:
vncviewer works with no problem but problem is running vncserver.

on one of this machines(all 5 ws same behavior) i have this error log in /.vnc/trieste3:1.log

# cat /.vnc/trieste3:1.log
01/10/09 11:25:43 Xvnc version 3.3.3r2
01/10/09 11:25:43 Copyright (C) AT&T Laboratories Cambridge.
01/10/09 11:25:43 All Rights Reserved.
01/10/09 11:25:43 See http://www.uk.research.att.com/vnc for information on VNC
01/10/09 11:25:43 Desktop name 'X' (trieste3:1)
01/10/09 11:25:43 Protocol version supported 3.3
01/10/09 11:25:43 Listening for VNC connections on TCP port 5901
01/10/09 11:25:43 Listening for HTTP connections on TCP port 5801
01/10/09 11:25:43 URL http://trieste3:5801
failed to set default font path '/usr/lib/X11/fonts/misc/,/usr/lib/X11/fonts/hp_roman8/75dpi/'
Fatal server error:
could not open default font 'fixed'

in that paths are the fonts files and calogues, "almost" same fonts files like on server (no font server runs) so no problem on that

I have all same binaries from server to trieste3 preserving groups owner and permissions.

i tried to give directly with -fp option:
# vncserver -fp /usr/lib/X11/fonts/hp_roman8/75dpi/
same result failed.

ws and server are B2000

Any help is apriciated!
Thanks
3 REPLIES
Steven E. Protter
Exalted Contributor

Re: VNC font path on some HP-UX 10.20

Shalom,

This error should not impact your test.

It is pretty common.

10.20 HP-UX is 5.5 years out of support. Wondering why there is a need to do anything with that OS outside of the US Navy.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
error1
Occasional Advisor

Re: VNC font path on some HP-UX 10.20

yes is very common, all forums are talking about this problem,
but i wonder, 2 almost same machines and on one vncserver run on other no way.

i did some modifications on vncserver script in -fp line and i added line -fn and i get now error:

Fatal server error:
could not open default cursor font 'cursor'

ideas?
thanks
error1
Occasional Advisor

Re: VNC font path on some HP-UX 10.20

Done
i copied /usr/lib/X11/fonts/misc/ from server(WORKING FONTS) to an tmp dir on trieste3
Then I have modified # vncserver -fp option points to /tmp fonts

Vnc in execution

THANKS