cancel
Showing results for 
Search instead for 
Did you mean: 

VNC on HPUX11.23

Nido
Trusted Contributor

VNC on HPUX11.23

Hi,
Looking for suggestion to fix the following problem.
VNC log file error:

/usr/lib/dld.sl: Bad magic number for shared library: /usr/local/lib/libstdc++.sl
/usr/lib/dld.sl: Exec format error


I'm running vncserver (vnc-4.1.3)on rp3410 having 11.23.

Thanks,
" Let Villagers Be Happy!! "
4 REPLIES
Dennis Handly
Acclaimed Contributor

Re: VNC on HPUX11.23

What does file(1) show for your executable and for /usr/local/lib/libstdc++.sl?
Are they both PA-RISC?

Re: VNC on HPUX11.23

Hi Ganesh:

It seems that the VNC executable is from PA-RISC and /usr/local/lib/libstdc++.sl is Itanium native library. You can confirm this by using file(1) command.

To fix the issue you need to install PA-RISC libgcc from

http://hpux.connect.org.uk/hppd/hpux/Gnu/libgcc-4.2.3/

in an alternate location other than /usr/local. Refer swinstall(1M) man page.

Alternatively, you can copy libstdc++.sl from PA-RISC HP-UX 11.23 to Itanium server.
- ensure that the copied library file has execute permission
- SDKROOT=/usr/ccs/pa chatr +s enable
- export SHLIB_PATH=:$SHLIB_PATH
- start vncserver and it should work fine.

Regards
-Rajesh
Dennis Handly
Acclaimed Contributor

Re: VNC on HPUX11.23

>Rajesh: /usr/local/lib/libstdc++.sl is Integrity native library.

If so, this system is very broken. On IPF, the libraries should go into lib/hpux##/ and be named libstdc++.so.
Nido
Trusted Contributor

Re: VNC on HPUX11.23

Hi,

As I informed, am using rp3410 and the lib files are in place as it should be.

This file's ownership is different than bin:bin >>> /usr/local/lib/libstdc++.sl


Problem got resolved after installing the later version .
vnc-4.1.2 is running fine on both the arch. ia64 and PA-RISC.

Thanks for all your help.
" Let Villagers Be Happy!! "