General
cancel
Showing results for 
Search instead for 
Did you mean: 

Very slow drive performance with RH9 on EVO N610C

David Bellizzi
Occasional Visitor

Very slow drive performance with RH9 on EVO N610C

1.8Mhz P4, 256Megs, 30 gig drive.Has anyone

1. Installed RH 9 on a 610C
2. Seen a high amount of disk access when using X apps like evolution, mozilla.
3. Figured out how to get around this?
4. Figured out how to get the screen to switch to > 1024x768 when going from undocked to docked?

Thanks.
db
I hate compaq laptops!
4 REPLIES
Steven E. Protter
Exalted Contributor

Re: Very slow drive performance with RH9 on EVO N610C

You may have a simple performance problem. I noticed marked degradation in performance in X Windows when I started upgrading my servers from Red Hat 7.3 to Red Hat 9 a few montths ago.

There is a little bloatware factor here I think.

What are your swap settings: In general for performance, I set swap to between 1 and 2 time physical memory. Too big and it slows you down, to small and applications can't reserver enough memory.

The video drivers and subsystems on these laptops are not known for performance either. You might want to check with the manufacturer for improved drivers.

Run gtop in X Windows and take a look at whats running.

You might want to collect performance data as well. I'm attaching(warily) an HP-UX sar(sar being pretty universal) data collection script. It runs background.

I imagine it will require extensive modification to work right on Linux, but the payoff is it really does identify many performance issues and bottlenecks. I'd be glad to help you port the script, but I'm going out of town and more than likely will not have access to my Linux boxes for two weeks.

Steven E. "works for points" Protter

Doh!
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
dirk dierickx
Honored Contributor

Re: Very slow drive performance with RH9 on EVO N610C

Well, mozilla and evolution are the 'bigger' user xwin apps running on linux. And they are known to consume some memory, although your 256MB should be enough. you could try another browser, since mozilla surely takes a lot of resources. 'galeon' is pretty good, but i don't think it is included in rh9.
check if your harddrive settings are optimal, use the 'hdparm' (/sbin) for this, and change/tweak some of the settings that are not correctly set. (be carefull, some of them are better left alone)
the 2.4 kernel has no mechanism yet to detect if laptops are un/docked, this is something for the nearing 2.6 kernel. the closest thing you can get now is to adjust your boot menu, and include entries for docked and undocked configurations.
Cristian Draghici_1
Frequent Advisor

Re: Very slow drive performance with RH9 on EVO N610C

Try xrandr to change resolutions "on the fly".

HTH
Cristi
David Bellizzi
Occasional Visitor

Re: Very slow drive performance with RH9 on EVO N610C

um, I believe the iusses are hardware related because my slower IBM laptop (PIII 850Mhz 512Meg) with an encrypted drive runs that same exact apps on RH 7.3 much much faster. My workmates have tried the same hardware with RH 7.3 with the same results. Yes with windows the drive are fast. Special driver? All seetings in /etc/sysconfig/harddisks are enabled but I see no difference. I'm going to investigate running hdparm manually.

The resolution issue seem to related to docked vs undocked because if the system is booted out of the dock the highest resolution that it will be display is 1024x768 even though my XF86Config has 1280x768 defined. Doing the Crtl - or + does not help. Once I reboot in the dock the system my higher resolution is reenabled.
I hate compaq laptops!