Re: Web Jetadmin 7.0 problem (Linux)

Sigurdur Bjornsson
Occasional Contributor

Web Jetadmin 7.0 problem (Linux)

I recently downloaded WJA 7.0 and tried to install it. The install went just fine, the WJA started up and everything looked good. But!.. after I rebooted the computer it won't start. When I try to start it, it says that WJA was started successfully, but there is no hpwebjetd process running. All I get is a line in error_log... "[DATE] [error] Cannot allocate shared memory: (17)File exists". If I do a complete uninstall and then re-install WJA, then it runs until the next reboot. I'm running Red Hat 7.3 (also tried 8.0 with same result).
If anyone has had this problem or knows a solution please post it here.
Kodjo Agbenu
Honored Contributor

Re: Web Jetadmin 7.0 problem (Linux)


I guess WebJetadmin needs lots of shared memory. During the first install, I guess it makes all necessary things to configure the system to be able to allocate that amount of shared memory.

However after subsequent reboots, the system default settings are applied (32Mb on Linux).

To change the maximum size of a shared memory segment :

echo "size_in_bytes" >/proc/sys/kernel/shmmax

To make sure that it is automatically configured by RedHat boot scripts, edit /etc/sysctl.conf and add :

kernel.shmmax = size_in_bytes

For exemple, to allow a single process to allocate up to 128 MB shared memory :

echo "134217728" >/proc/sys/kernel/shmmax

To do the same in system startup scripts, edit /etc/sysctl.conf as follows :

kernel.shmmax = 134217728

Good luck.

Learn and explain...
Mark Fenton
Esteemed Contributor

Re: Web Jetadmin 7.0 problem (Linux)

So building on Kodjo's post --

Install the App and then do a
cat /proc/sys/kernel/shmmax
then plug the resultant number into your sysctl.conf

or, read the documentation and find out how much shared memory it requires and plug that number in.

Best regards,