General
cancel
Showing results for 
Search instead for 
Did you mean: 

Weird df issues on RedHat 2.1

TJ_16
Frequent Advisor

Weird df issues on RedHat 2.1

df is reporting the wrong size.

for example:

df -h /appl
Filesystem Size Used Avail Use% Mounted on
/dev/vx/dsk/oradg/vol16
50G 45G 5.3G 90% /appl


Now what du shows:
du -sch *
686M LifeRay-3.2.0
31M apache-ant-1.6.2
135M cingularmog
118M dishmog
30k ftp
2.2M ipa
1.0k liferay.kill
0 lost+found
100M phone-book
78M qhSMS
17M qhccv
24M qhrush
3.2M qhwat
2.0k security
2.0k setenv_ccv
1.0k setenv_wat
11k spott-cf-reports
50M spott_phonebook
13k ssl
0 test
1.0k test.log
1.0k test.properties
1.0k xxx.txt
1.3G total


This is a Veritas disk and the Veritas GUI also reports the same as df...

Any ideas?

2 REPLIES
Ivan Ferreira
Honored Contributor

Re: Weird df issues on RedHat 2.1

Are any of these directories a mount point for other filesystem? I mean, is there anything mounted under /appl. Maybe a sparse file?
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
TJ_16
Frequent Advisor

Re: Weird df issues on RedHat 2.1

no, there are no other file systems mounted under /appl...

It is showing the correct size now...

I ran vxtunefs on it and it fixed it...

not sure how or why.