General
cancel
Showing results for 
Search instead for 
Did you mean: 

What will be the significance of PA-RISC2.0 being used in perl on HP-UX 11.11

sasikala
Advisor

What will be the significance of PA-RISC2.0 being used in perl on HP-UX 11.11

Hi,

I'm using perl-5.8.8(PA-RISC2.0) in HP-UX 11.11.

I'm also using Pro*C which is compiled in 32-bit.

Is this meant that i'm working onto 64-bit.

Regards
Sasikala
4 REPLIES
H.Merijn Brand (procura
Honored Contributor

Re: What will be the significance of PA-RISC2.0 being used in perl on HP-UX 11.11

PA-RISC 2.0 supports 64bit, but that doesn't say it has to be 64bit.

1. Both the application (perl) and the target (Oracle) have to be in the same bitness, otherwise the (shared) libraries won't work. If your Oracle is 32bit, you will need a 32bit perl, no matter what architecture (PA-RISC or Itanium) and no matter what OS level (10.20, 11.00, 11.11 (11iv1), or 11.23 (11iv2).

2. Check what your current perl is with

# perl -v

If that line mentions 64bit, like

This is perl, v5.8.7 built for IA64.ARCHREV_0-LP64

on Itanium, or

This is perl, v5.8.5 built for PA-RISC2.0-LP64

then it is a 64bit build.

For other 32bit/64bit build questions, please read my FAQ, or search the forum. It's been asked at least 4 times every week.

Enjoy, Have FUN! H.Merijn
Enjoy, Have FUN! H.Merijn
sasikala
Advisor

Re: What will be the significance of PA-RISC2.0 being used in perl on HP-UX 11.11

Thanks,

The command perl -v shows

This is perl, v5.8.8 built for PA-RISC2.0

and the database used is oracle10g (build in 64-bit)

SQL*Plus: Release 10.2.0.2.0 - Production on Fri Sep 22 07:19:06 2006
Copyright (c) 1982, 2005, Oracle. All Rights Reserved.
Connected to:
Oracle Database 10g Enterprise Edition Release 10.2.0.2.0 - 64bit Production
With the Partitioning, OLAP and Data Mining options

but when i execute some perl programs it is giving
/usr/lib/dld.sl: Bad magic number for shared library:

for this i have set SHLIB_PATH to point to lib32. Why this bad magic error is comming.
H.Merijn Brand (procura
Honored Contributor

Re: What will be the significance of PA-RISC2.0 being used in perl on HP-UX 11.11

your perl is 32bit, oracle is 64bit.

Get yourself a 64bit perl. Where did this one come from?

You can get a recent version from my site:

My HP ITRC site pages can be found at (please use LA as primary choice):

USA Los Angeles http://mirrors.develooper.com/hpux/
SGP Singapore https://www.beepz.com/personal/merijn/
USA Chicago http://ww.hpux.ws/merijn/
NL Hoofddorp http://www.cmve.net/~merijn/

Enjoy, have FUN! H.Merijn
Enjoy, Have FUN! H.Merijn
Alzhy
Honored Contributor

Re: What will be the significance of PA-RISC2.0 being used in perl on HP-UX 11.11

There is A signficance if you've Perl built with DBD/DBI against say a 64bit Oracle version...

My Perl is also 64bit, DBI Oracle is built against Oracle 9.x's 64bit libraries...

But as far as simple/general usage of Perl - it does not matter if you are using 32bit or 64bit Perl... Of course if you are dealing with very large data structures, I believe 64bit Perl is needed since it will be able to address memory beyond the 4GB limit of 32 bit apps.

Am I correct O Great Merjin?

;^)
Hakuna Matata.