Re: X config problem on 845 chpiset

Subrata Bal
New Member

X config problem on 845 chpiset


I am having problem in getting the display for my PC. This PC have P$ TITAN 667 (GA-8GE667 Pro, Intel 845GE chipset) mother board and have a built in display card. I have gone through the messeges of X V. Bindumadhava on similar problem and corresponding replies by Kodjo Aqbenu. And tried to modify the XF86Config-4 file changing the Driver "vesa".
But I still have problem.
I get the display for few seconds after booitng, but after that it disappears to give a black screen. I should mention the screen i am using is Sharp LL-T1530A
and have maximum resolution of 1024x768. i am attaching 1) the result of lspci -v
2) file /etc/X11/XF86Config-4
3) file /var/log/XFree86.0.log

can any one please help me in this regard.

Thanking you in advance.

Trusted Contributor

Re: X config problem on 845 chpiset

linux version ?????
Subrata Bal
New Member

Re: X config problem on 845 chpiset

Dear Mr/Mrs. Chakravarthi,

Thanks for your prompt reply. I am sorry that I fotgot to metion that I am using Redhat Linux 7.2 in my earlier mail.

Thank you again,

Best regards,

Kelli Ward
Trusted Contributor

Re: X config problem on 845 chpiset

Hi Subrata,

Have you tried to use the Xconfigurator command to probe your graphics?

It might help you,

Good luck,
The more I learn, the more I realize how much more I have to learn. Isn't it GREAT!
John Meissner
Esteemed Contributor

Re: X config problem on 845 chpiset

Have you downloaded an updated linus driver for your video card? A friend of mine had a similar problem with this. He also had a problem that after a while his screen would go black. It turns out that Dell had to replace his video card/motherboard in his laptop.
All paths lead to destiny
Subrata Bal
New Member

Re: X config problem on 845 chpiset

I have tried Xconfigarator. But it did not help. I have n't updated the linux driver for my video card. Actually this chips seems to be very new. And I dont know wheather linux driver for this Intel 845 GE is available or not. In case any one knows about it please let me know.


Best regards

Stuart Browne
Honored Contributor

Re: X config problem on 845 chpiset

From a bit of reasearch, it seems that there are 2 related issues with this series of video card.

One is detailed here:

This basically states what was mentioned in the other thread of this topic (use the 'vesa' driver). It also states that newer versions of XFree86 include peliminary support for the 845 in the 'i810' driver.

The second issue has to do with various BIOS' bad habbit of forcing a 1MB buffer on the card, meaning you can't use any decent resolutions. Changing this in the BIOS to be 8MB or so usually fixes this problem, but you may also need to force the X config to see that it has that much memory (in the video device, the setting 'VideoRam'). This is discussed in the thread:

(note: most of the stuff in this thread is garbage, but there's a few posts which are decent).

Depending on what distribution you are using (haven't seen it mentioned in either thread thus far), and how well you can cope with updating packages, you might want to try updaing both the Kernel (to 2.4.20) and X (to the pre-release

These latest releases have a number of fixes in place for the intel 845 video chipset.

Hope this helps somewhat.
One long-haired git at your service...