General
cancel
Showing results for 
Search instead for 
Did you mean: 

XFree 4 and the Intel i815 chipset

Olivier ROBERT
Frequent Advisor

XFree 4 and the Intel i815 chipset

Dear Forum readers,

I use an HP Vectra VL400 with an Intel i815 Chipset Graphics Controller, and run Linux Mandrake 9.0 on it. A few X servers are running simultaneously on this machine. The problem is that regularly, the X servers crash and garbage displays on the screen. I manage to switch to a text virtual console, e.g. tty1, but the same garbage remains on the screen. I know that I'm on a text virtual console since I do a blind login, type 'echo -e "\a"' and it beeps. Any try to restart an X server fails, with the error message "Fatal server error: Active ring not flushed". I noticed that even though the X servers are no longer running, /dev/tty7 can't be deallocated with deallocvt ("Resource busy"), and an "fuser /dev/tty7" says nothing.
I tried with FreeBSD too, but it's even worse, and the display systematically crashes. I suppose it comes from XFree 4.
The only way I found to be able to start the X servers again is a REBOOT. I hate that...
My questions are:
- Is this a known bug?
- Is there a released solution?
- If not, how could I restart my X servers without having to reboot?

I know that Intel released an XFree 3 server but I want XFree 4... And switching to Windows would be an off-topic solution.
Thanks for your help!

Olivier ROBERT
2 REPLIES
Stuart Browne
Honored Contributor

Re: XFree 4 and the Intel i815 chipset

I'm unsure what release of XFree86 4 comes with Mandrake 9, but I know that the latest releases do work quite well on i815 chipset's.

You might want to try updating the packages from Mandrake, or grab the binaries directly from the XFree86 project (www.xfree86.org).

That is also the best place to look for and talk about bugs like this.
One long-haired git at your service...
Olivier ROBERT
Frequent Advisor

Re: XFree 4 and the Intel i815 chipset

Thanks Stuart,

Mandrake 9.0 ships with XFree 4.2.1, which is the latest version (well, yesterday it was, I didn't check today...). Eventually, I submitted a detailed bug report at the XFree86 web site already... And I can confirm you that some configurations are catastrophic with the Intel i815 chipset. Just after installation, the servers were crashing every two or three hours, I solved that by deactivating the GLX extension and direct rendering (fortunately I don't need that). Now it crashes every three weeks, that's better, but yet to be improved! :o)
Regards,

Olivier