General
cancel
Showing results for 
Search instead for 
Did you mean: 

Xfree4 + Nvidia Geforce2MX + compaq TFT5015

Xfree4 + Nvidia Geforce2MX + compaq TFT5015

I can't manage to launch Xfree4.1 with nvidia accelerated drivers, on Compaq TFT5015 monitor.
With other monitors, it works.
(I get the NVIDIA logo and glxgears works fine)
But with TFT5015, there is a problem with the v- and h-sync, or modelines.
Does anybody has the right modelines, v- and h-sync, and resolution ?

Thanks
Waterloo morne plaine
4 REPLIES
Bill Thorsteinson
Honored Contributor

Re: Xfree4 + Nvidia Geforce2MX + compaq TFT5015

Get the readedid package and see if the monitor is responding. You can also get this information by starting the xwindow server with the verbose option

startx -- --verbose --logverbose

If you aren't getting the information from the monitor you will have to set the information in the monitor section of the XF86config-4 file. It should be overriden if you connect a monitor that does supply the information.

Re: Xfree4 + Nvidia Geforce2MX + compaq TFT5015

No way
I tried readedid, that doesn't work, and ddcprobe.

I tried a lot of modeline combinations and H+V, but nothing works.



Waterloo morne plaine
Vincent Stedema
Esteemed Contributor

Re: Xfree4 + Nvidia Geforce2MX + compaq TFT5015

Hi,

According to http://h18004.www1.hp.com/products/quickspecs/10896_div/10896_div.HTML , the vsync is 31.47 - 61 kHz and the hsync is 56-75 Hz.

Personally, I don't use mode lines. Adding the above values to your configuration file should be enough.

Regards,

Vincent

Re: Xfree4 + Nvidia Geforce2MX + compaq TFT5015

Sous Linux avec Xfree4, j'ai constaté un problème pour faire fonctionner
les drivers accélérés 3D propriétaires de NVidia avec l'écran plat TFT5015 Compaq.

Le symptôme est le suivant: le gestionnaire d'affichage refuse de prendre en
compte les fréquences de balayage verticales et horizontales que nous lui imposons:
HorizSync 31-61
VertRefresh 56-75

J'ai constaté qu'au lancement du serveur d'affichage X, le driver
interroge le moniteur, mais les valeurs renvoyées sont erronées (je ne sais
pas qui est en cause, entre le serveur d'affichage, le driver NVidia et l'écran
lui-même)

Heureusement, il est possible de désactiver la fonction d'interrogation du
moniteur, et tout rentre dans l'ordre:

(IT IS POSSIBLE TO DEACTIVATE THE QUERY OF THE MONITOR BY NVIDIA CARD, AND EVERYTHING BECOME FINE)

Dans /etc/X11/XF86Config-4:
Section "Device"
# no known options
Identifier "NVIDIA GeForce"
#Driver "nv"
Driver "nvidia"
VendorName "NVIDIA"
BoardName "NVIDIA GeForce"
Option "IgnoreEDID" "true"
EndSection


Et la documentation de NVidia à ce sujet:
Option "IgnoreEDID" "boolean"
Disable probing of EDID (Extended Display Identification Data) from your
monitor. Requested modes are compared against values gotten from your monitor
EDIDs (if any) during mode validation. Some monitors are known to lie about
their own capabilities. Ignoring the values that the monitor gives may help get
a certain mode validated. On the other hand, this may be dangerous if you don't
know what you are doing.
Waterloo morne plaine