Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

any dba's out there ?

steven Burgess_2
Honored Contributor

any dba's out there ?

morning all

I'm having a little trouble shutting down a database following a failed disk. The server is dev so data isn't mirrored. Disk is an fc in fc10 array

I tried to shutdown the package which failed miserably and timed out

I have tried as oracle with

sqlplus /nolog
shutdown immediate

This failed also

shutdown abort

Just hangs

The disk is showing NO_HW

Whats the best thing I can do ?

Thanks in advance

Steve
take your time and think things through
3 REPLIES
Bill Hassell
Honored Contributor

Re: any dba's out there ?

Like any disk failure, the application is likely going to hang until the I/O completes. The data may or may not be valid. There's really nothing you can do to gracefully shutdown the database as it is trying to post memory resident data and tghe disk is dead. kill -9 or reboot the server. Either way, your data is going to need a lot of repair.


Bill Hassell, sysadmin
steven Burgess_2
Honored Contributor

Re: any dba's out there ?

Hi Bill, thanks for the reply

Thought so, I have an engineer on the way with a new disk.

I have arranged tapes from the last full backup, will get the disk swapped, recreate the file system then the data recovered.

Will then let our dba's sort out the recovery of the database

Thanks again

Steve
take your time and think things through
Steven E. Protter
Exalted Contributor

Re: any dba's out there ?

Do bring down the database you'll need to do shutdown abort.

Since that has failed there is another kind of shutdown abort.

fuser -cuk /filesystem_of_the_database

That will shut it down. It will want to recover.

Procedure for quickly getting back on line.

vgreduce -f /dev/vg##

It will blow the bad disk out of the volume group and give you a procedure right after completion for putting the vg back together.

I think its:
mv /etc/lvmtab /etc/lvmtab.old

vgscan -av

Then once the disk is in:

#I always forget whether you pvcreate on block or character device.
pvcreate -f /dev/rdsk/c#t#d#


vgextend /dev/vg## /dev/dsk/c#t#d#

You should be able to do extendfs on the fileystem to get it back on that disk.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com