cancel
Showing results for 
Search instead for 
Did you mean: 

autofs on Linux

Anubhav Dhingra
Frequent Advisor

autofs on Linux

Hi,

I am using autofs to mount the nfs file systems. However, when i do df -kh these filesystems does not appear and even when i go inside the mount point, it does not show anything.

Below is : /etc/auto.master
/misc /etc/auto.misc
#
# NOTE: mounts done from a hosts map will be mounted with the
# "nosuid" and "nodev" options unless the "suid" and "dev"
# options are explicitly given.
#
/net -hosts


/pretupsvar_trans01 /etc/auto.pretupsvar_trans01 --timeout=30
/pretupsvar_trans02 /etc/auto.pretupsvar_trans02 --timeout=30

more /etc/auto.pretupsvar_trans01
pretupsvar_trans01 -fstype=nfs,ro,nosuid,soft ml-trans01:/pretupsvar/


more /etc/auto.pretupsvar_trans02
pretupsvar_trans02 -fstype=nfs,ro,nosuid,soft ml-trans02:/pretupsv
ar/

showmount from the server is as follows:

showmount -e
Export list for ml-trans02:
/pretupsvar ml-loggsrv01

showmount -e
Export list for ml-trans01:
/pretupsvar ml-loggsrv01

Also, when i put the entries in /etc/fstab,,, it works but not through autofs.
Please suggest.

5 REPLIES
Jayakrishnan G Naik
Trusted Contributor

Re: autofs on Linux

>>>I am using autofs to mount the nfs file systems. However, when i do df -kh these filesystems does not appear and even when i go inside the mount point, it does not show anything

Hi

From the above statement, I am sssuming that you can access the filesystem mounted using autofs but cannot see them by df command. Am I right?

Which version of linux you have?

I have some info regarding this for you from df manpage. Can you try df -a or df --all after changing directory to your autofs filesystem? Find the details of -a or --all option, below.

`-a'
`--all'
Include in the listing filesystems that have a size of 0 blocks, which are omitted by default. Such filesystems are typically
special-purpose pseudo-filesystems, such as automounter entries.Also, filesystems of type "ignore" or "auto", supported by some
operating systems, are only included if this option is specified.

Now, more information about similar kind of information I got from internet.Following quotes are from internet.(link at the end)


" All my servers use autofs to mount user directories from the one central file server and all seems fine. Last night I completed the final upgrade to the main file server, all is working just about fine, but I notice that df does not show any of the filesystems mounted with autofs on the file server, however cat /proc/mounts shows all the mounted directories correctly. df -a also shows the directories mounted!

I can only imagine that this is a new feature so df does not show autofs mounted from the local machine.

Am I missing something?

I'm not sure about the output of df for other than for the autofsmounts, I would expect it to show the other mounts. The autofs filesystem mounts aren't done using mount in version 5 so they shouldn't
normally show up in df output"

http://www.mail-archive.com/rhelv5-list@redhat.com/msg02911.html

Hope this helps to clarify your doubts. If you find this helpful, do not forget to assign appropriate points.

Thanks & Regards
Jayakrishnan G Naik
Anubhav Dhingra
Frequent Advisor

Re: autofs on Linux

Hi,

Thanx for the quick reply... However, I am unable to see the list of files in the mounted filesystems...
when i do ll or anything...
df -a
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/mapper/VolGroup00-LogVol01
20314748 6794432 12471740 36% /
proc 0 0 0 - /proc
sysfs 0 0 0 - /sys
devpts 0 0 0 - /dev/pts
/dev/mapper/VolGroup00-LogVol05
74718304 184220 70677292 1% /logs
/dev/mapper/VolGroup00-LogVol04
15236080 169640 14280008 2% /home
/dev/mapper/VolGroup00-LogVol02
5078656 2974340 1842172 62% /var
/dev/mapper/VolGroup00-LogVol03
5078656 152860 4663652 4% /tmp
/dev/cciss/c0d0p1 101086 20384 75483 22% /boot
tmpfs 6082576 0 6082576 0% /dev/shm
/dev/mapper/vglogs-logs1
705552568 201864 669510704 1% /logs1
/dev/mapper/vglogs-logs2
705552568 201864 669510704 1% /logs2
none 0 0 0 - /proc/sys/fs/binfmt_misc
sunrpc 0 0 0 - /var/lib/nfs/rpc_pipefs
[root@ml-loggsrv01 pretupsvar_trans01]# pwd
/pretupsvar_trans01
[root@ml-loggsrv01 pretupsvar_trans01]#
Jayakrishnan G Naik
Trusted Contributor

Re: autofs on Linux

hi

What does cat /proc/mounts show?

Can you copy here?

Thanks & Regards
Jayakrishnan G Naik
Jayakrishnan G Naik
Trusted Contributor

Re: autofs on Linux

Hi

The link I given in my first reply, gives an idea of similar situation faced, so you can compare your Os version and kernel version with that and see whether there is a match.

If so you may need to have some patching to overcome this. Copying the link again below.

http://www.mail-archive.com/rhelv5-list@redhat.com/msg02911.html



Regards
Jayakrishnan
Anubhav Dhingra
Frequent Advisor

Re: autofs on Linux

thanx