Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

booting RH8.0 from scsi and lvm "/"

S.C. Fun
Advisor

booting RH8.0 from scsi and lvm "/"

Hello experts,
Sorry to elaborate a long story first because I couldn't find an exact match in your archive:

My machine(hp vectra vl):
AMD 133Mhz 64MB (just don't want to leave it in store room)
1x1GB built-in IDE HDD
1x4GB FW-SCSI HDD connected to PCI-SCSI controller
1xDDS Tape drive connected to PCI-SCSI controller

My setup:
RH 8.0 only
boot loader: GRUB in MBR /dev/sda
partition layout:
/dev/hda created as LVM device (/dev/vg01), no LV created
/dev/sda:
/boot created as ext3
the rest created as LVM with the following Logical Volume:
/ /dev/vg00/lvol1
swap /dev/vg00/lvol2
/usr /dev/vg00/lvol3
/home /dev/vg00/lvol4
/var /dev/vg00/lvol5
/opt /dev/vg00/lvol6

Installation complete without giving any error.

My problem 1:
After installation, system reboot & stop at GRUB>

My problem 2:
Tried boot from floopy failed, stop at RAMDISK ...

During installation, I also encounter many times of "DEBUG" dialog boxes when configuring the partitions, I have no choice but to click OK and reboot to try until success.

I have done all the above for more than 10 times and already tried the followings as well:
1. Tried LILO -> same message GRUB>
2. Tried dd if=/dev/zero of=/dev/hda count=10 -> OS not found
3. Tried install boot loader in MBR /dev/hda -> same message GRUB>

BTW, there should be no H/W problem because the devices has been installed with RH7.2 without problem (I put /boot in /dev/hda previously).

My questions:
1. I want to use the SCSI disk to contain all Linux OS without touching the IDE drive, how to make it booting Linux from SCSI disk?
2. Since /boot could not be in LVM, I leave it as ext3 and all other FS in LVM including "/". Is there any problem mounting "/" in LVM during booting?

Thank you in advance.
2 REPLIES
Kodjo Agbenu
Honored Contributor

Re: booting RH8.0 from scsi and lvm "/"

Hello,

This is a complex issue as it involves the following :

=> Booting a scsi device via a PCI scsi controller.

This is possible if the SCSI controller has its own BIOS. Hence, the first time you boot you may need to press something on the keyboard to enter the SCSI card's BIOS setup. Then make your it is properly configured (selection of BOOT device, no SCSI ID conflict between the disk and the tape drives, ...).

If your SCSI controller have no BIOS, then you MUST boot on the internal IDE driver. This means MBR + /boot !!!

Why /boot ? Because at the boot time, the BIOS does not know how to address SCSI devices, so it cannot read the Linux kernel code located in /boot on the SCSI device.


=> Boot with root filesystem on LVM device.
This should be OK if you load the "lvm-mod.o" driver in the initial ramdisk, and if you instruct the kernel properly to switch between the ramdisk and the real root device.

On you ramdisk, you may have something like this :

insmod
insmod scsi_mod.o
insmod sd_mod.o
insmod lvm-mod.o
...
...
mount /proc
...
...
vgscan
vgchange -a y
...
...
mkrootdev
echo >/proc/sys/kernel/real-root-dev
mount
...
umount /proc
pivot_root


Something may be wrong in this sequence.

If you need more help on this, please do the following :

* Boot your RedHat installation CD, follow the instructions until the keyboard is properly selected

* Open a shell (CTRL-ALT-F2).

mkdir /test
mknod /dev/sda b 8 0
mknod /dev/sda1 b 8 1
mount -t ext3 /dev/sda1 /test

mkdir /floppy
mknod /dev/fd0 b 2 0

mount -t msdos /dev/fd0 /floppy

cp -p /test/ /floppy

umount /floppy
umount /test

reboot


Then post the initrd file collected. I'll try to find what is wrong.


Good luck.

Kodjo
Learn and explain...
S.C. Fun
Advisor

Re: booting RH8.0 from scsi and lvm "/"

Thanks Kodjo. I will reconfigure my system back to the above config. since I have tried out so many other options. Then, I will upload the required file.

FYI, I have changed the PCI-SCSI boot rom to boot from SCSI device ID=2, which is the 4GB SCSI HDD. However, there's no option menu to choose to boot from floopy/CD/hdisk in PC BIOS (it's an old PC anyway).

Meanwhile, I will give u 4 points for your effort in taking time to read my long grandfather story and help troubleshooting. Hope u will continue to assist to solve my problem. Stay tuned!