Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

can't see my automounted directory

joseph wholey
Regular Advisor

can't see my automounted directory

can't see my automounted filesystem. Here are my relevant files and setup. I set up the files then started autofs with "service autofs start". It succeeds, as noted in the log, but I expect to be able to see the directory "jwholey" under /u. /u is crated and has permissions of 755.

auto.master:
#
# $Id: auto.master,v 1.3 2003/09/29 08:22:35 raven Exp $
#
# Sample auto.master file
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# For details of the format look at autofs(5).
#/misc /etc/auto.misc --timeout=60
#/misc /etc/auto.misc
#/net /etc/auto.net
/u /etc/auto.u

auto.u
jwholey pw0103e0:/myhome:&

ls -la | grep u
drwxr-xr-x 2 root root 0 Mar 31 15:28 u

/var/log/messages:
Mar 31 15:28:08 rhel012 autofs: automount startup succeeded

Any ideas? thx.
4 REPLIES
Stuart Browne
Honored Contributor

Re: can't see my automounted directory

It's an auto-mount. It won't mount until it's used.

So try doing a 'cd' or something of '/u/myhome', then you should see it.

If you want it to mount when the system starts up, use '/etc/fstab' instead, and make it a permenant mount point.
One long-haired git at your service...
Ivan Ferreira
Honored Contributor

Re: can't see my automounted directory

Reload the service

service autofs reload

And as indicated abuve, do:

cd /u/jwholey
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
joseph wholey
Regular Advisor

Re: can't see my automounted directory

I did reload as suggested... nothing.
Ivan Ferreira
Honored Contributor

Re: can't see my automounted directory

Try configuring our auto.u like this:

auto.u
* -rw,soft pw0103e0:/myhome/&

Also, the output of:

showmount -e pw0103e0

will help
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?