cancel
Showing results for 
Search instead for 
Did you mean: 

cannot start X windows

Yong Shiuh Rong
Frequent Advisor

cannot start X windows

I change my graphic card from Geforce2 to Geforce4 when I use Redhat 8.0, yesterday I upgrade to Redhat 9.0, the system prompt me whether to keep the setting for my video card, but i ignore and now I can't start the Linux X windows.

The system ask me to change the setting, what should I change and where can I find the config file?
6 REPLIES
Steven E. Protter
Exalted Contributor

Re: cannot start X windows

You need to run the xconfigurator

That will once again prompt you for your video information.

This time answer the questions correctly, make sure the DISPLAY variable is properly set and if the setup is supported, all will be well.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Yong Shiuh Rong
Frequent Advisor

Re: cannot start X windows

Steven, how to run the xconfigurator? Is it on the startup of Linux?

now everytime I start my Linux it will prompt me the question, eventhough I answer the question correctly, I can't start X windows as well.
Jeff Moon
Occasional Visitor

Re: cannot start X windows

I don't know about RedHat 9.0 specifically, but in most other Linux distros, you can run xf86config as root and it will prompt you for all the information that it needs.
Alexander Chuzhoy
Honored Contributor

Re: cannot start X windows

for redhat distributions you should run
redhat-config-xfree86 utility
bong_3
Advisor

Re: cannot start X windows

not so sure about RH9 but you can try this...

>Log as root
>First you must be in runlevel 3

>(edit the /etc/inittab, change the 5 to 3 and reboot)

>run 'XFree86 -configure'

the screen will go black for a little while.
that will generate a file 'XF86Config.new'
(assuming you're logged in as root)
to test, type 'XFree86 - xf86configure /root/XF86Config.new'

>rename the file '/etc/X11/XF86Config'

>Copy the '/root/XF86Config.new' file to be your new '/etc/X11/XF86Config'
file

>type 'startx' to test.

if you have any problems like the mouse not working, you can copy the old
settings from your old XF86Config into the new one.

rgds,
Bong

Re: cannot start X windows

Boot in to linux in single mode if it getting hung will loading xwindow. if its not hanging during logging, then login as root and issue the command Xconfigurator(X is caps), and configure the video card and monitor resolution. And if your not able to find the appropriate device in the list, then dowload the appropriate driver preferably .rpm, which will make your installation easier.

After configuring the video card, issue the command startx.

Kind Regards,
Manoj Kumar A