cancel
Showing results for 
Search instead for 
Did you mean: 

connecting windows to UNIX

saad_5
Occasional Contributor

connecting windows to UNIX

i just install fedora core 4
and i tried to connect remotrely from my windows desktop to the server (UNIX core 4).

1- i can ping but i cannot telnet.

2- when i used Exceed some time it works and some time not, and when i tail (tail -f /var/log/messages) i found the messages:
- session opend for user ...
- session closed for user ...
- gdm_child_action: Aborting display win2k3:0
and sometimes i get diesel3:0 or citrixp:0 insted of win2k3:0

thanx

Saad,
3 REPLIES
Kodjo Agbenu
Honored Contributor

Re: connecting windows to UNIX

Hi,

Telnet is disabled by default on "modern" Unix systems (and I include Linux in this category).

It is better to use ssh as connections are encrypted. You can download PUTTY that is an excellent ssh client for Windows :

http://the.earth.li/~sgtatham/putty/latest/x86/putty.zip

If you want to connect using X11, you can do it two ways :

1 - Export your display

Launch Exceed on your Windows box.

Launch putty, then go to the menu "Connection => SSH => Tunnels" and check the box named "Enable X11 forwarding". Then, launch an SSH connection to your Linux box.
Test your X11 connection using xterm : it should display on your Windows desktop (Exceed).

2 - XDMCP

XDMCP is the protocol using by your display manager (eg : GDM).

To enable XDMCP, logon as root on Linux, then :

=> In /etc/opt/gnome/gdm/gdm.conf :

...
...
[xdmcp]
Enable=true
...
...


=> In /etc/X11/xdm/Xaccess

...
...
* CHOOSER BROADCAST
...
...


=> In /etc/X11/xdm/xdm-config

...
...
DisplayManager.requestPort: 177
...
...


After changing these parameters, re-start your display manager (either gdm or xdm), then try a connection from Exceed : you should get a login window.

Good lcuk.
Kodjo
Learn and explain...
Steven E. Protter
Exalted Contributor

Re: connecting windows to UNIX

For connection and/or configuration, you should use secure shell.

http://www.networksimplicity.com/openssh


Make sure iptables is not running on the Linux box.

chkconfig --list iptables

service iptables status

service iptables stop # if running,

Then try again.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
saad_5
Occasional Contributor

Re: connecting windows to UNIX

thanx for your cooperation
but still nothing changed
i have the same problem i cannot see any login window.