Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

corn jobs not working properly

SOLVED
Go to solution
YAQUB_1
Respected Contributor

corn jobs not working properly

Hi There,

I have a script in cron that copy my data files from one folder to another on daily basis, some of the data files are larger than 2 GB, and /var/mail/oracle is showing me following errors regarding the script execution:

cp: /u02/oradata/TABSTST/TABS_DATA01.dbf: File too large

a /u01/daily_cold_backup/TABSTST/system01.dbf 819216 blocks
a /u01/daily_cold_backup/TABSTST/undotbs01.dbf 4014096 blocks
Can't open /dev/tty to prompt for more media.

Would you help me in this respect please?

4 REPLIES
A. Clay Stephenson
Acclaimed Contributor

Re: corn jobs not working properly

Your second list looks like it i tar's 'v' output. Unless patched, tar has a 2 GiB filesize limit. Since you didn't bother to indicate your OS version, I won't bother to look up the appropriate patch but the patched version of tar (of the Gnu version) will support a maximum filesize of 8GiB. Look in that patch database for tar.
If it ain't broke, I can fix that.
YAQUB_1
Respected Contributor

Re: corn jobs not working properly

Hi Stephenson,

My system rp7420 & OS 11i v1.

Thanks-Yaqub
James R. Ferguson
Acclaimed Contributor
Solution

Re: corn jobs not working properly

Hi:

If you are using 'cp' and receive a "file too large" error, then your destination filesystem probably doesn't have 'largefiles' enabled. There are several easy ways to ascertain whether or not a filesystem supports largefiles:

# fsadm -F vxfs /mountpoint

# mkfs -m -F vxfs /dev/vgXX/lvolN

...either will show 'largefiles' or 'nolargefiles'.

If you find that you need to convert a nolargefiles to a largefiles filesystem, do:

# fsadm -F vxfs -o largefiles /mountpoint

...if you have OnlineJFS installed. Otherwise you will need to unmout the filesystem and do:

# fsadm -F vxfs -o largefiles /dev/vgXX/rlvolN

*Note* the use of the raw device --- 'rlvolN'.

As for an 11.11 version of 'tar' that supports files up to 8GB in size, you can install:

PHCO_28992

No reboot is required.

Regards!

...JRF...




YAQUB_1
Respected Contributor

Re: corn jobs not working properly

Hi All,

Thanks for your all unique support.

Best Regards,
Yaqub.