Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

datafile larger then 2048 Mo

SOLVED
Go to solution
bruandet
Occasional Advisor

datafile larger then 2048 Mo

Hello,
Following install ORACLE 9;
The DBA with created files superior to 2048 Mo. And no error.Then the data were imported successfully and no error. But when the dBa makes a copy of table in sql it obtains this message:

ERROR at line 1:
ORA-01116: error in opening database file 6
ORA-01110: data file 6: '/U02/oradata/GPF/users01.dbf'
ORA-27092: skgfofi: size of file exceeds file size limit of the process
Additional information: 262143
Additional information: 448001
--------------------
J looked at the value of ulimit and:

# uxsar13:/> ulimit -a
time(seconds) unlimited
file(blocks) unlimited
data(kbytes) unlimited
stack(kbytes) 29296
memory(kbytes) unlimited
coredump(blocks) 4194303
nofiles(descriptors) 1500

What to make? and why 262143 (2 Go)
and when DBA reduce file under 2 Go, that working !

regards.
Julien.
8 REPLIES
Jean-Luc Oudart
Honored Contributor

Re: datafile larger then 2048 Mo

This is explained (somewhat) in metalink noteid 124822.1

I guess your oracle block size is 8Kb.

1) What is the user used for the SQL copy (Unix user , local or remote)

2) What is the ulimit of this user ?
ulimit for the user who starts the listener ?

3) Shell used : ksh or POSIX shell ?

Regards,
Jean-Luc
fiat lux
Nicolas Dumeige
Esteemed Contributor

Re: datafile larger then 2048 Mo

Bonjour Julien,

Take a look at this thread :
http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=550089

Same thing with oerr
ksh> oerr ora 27092
27092, 00000, "skgfofi: size of file exceeds file size limit of the process"
// *Cause: an attempt was made to open a file that exceeds the process's
// file size limit (ulimit), additional information shows the current
// limit (logical blocks) and the size of the file (logical blocks)
// *Action: increase the processes file size limit (ulimit) and retry

It's seems that the problem is with ulimit, whether it's not tested for the Oracle user or because there is a flaw in ksh.

Cheers

Nicolas
All different, all Unix
bruandet
Occasional Advisor

Re: datafile larger then 2048 Mo

I check 124822.1 in metalink.
And my db block size is 8kb.

1) user for sql copy is Unix user local (gpfadm)
and when I do ulimit -a for this user I have :

gpfadm:/home/gpfadm > ulimit -a
ksh: ulimit: bad option(s)

and when I do ulimit
gpfadm:/home/gpfadm > ulimit
4194303

user who launch oracle is oracle9 and when I do ulimit thas is same of user gpfadm
:ulimit -a
ksh: ulimit: bad option(s)
ulimit
4194303


3) Oracle are installed whith user oracle9 in sh, but that I chosse then in Ksh.



Jean-Luc Oudart
Honored Contributor

Re: datafile larger then 2048 Mo

Use POSIX-shell
and try again

Regards,
Jean-Luc
fiat lux
T G Manikandan
Honored Contributor
Solution

Re: datafile larger then 2048 Mo

I would check the below things

1.check the .profile file of the oracle user to see whether the oraenv script is present in the startup file.

THis oraenv file sets the ulimit value as 4194303
.

Remove the script from .profile or change the script from "4194303
" to "unlimited" in the "if condition".
If that is not present.

2.Load the patches
PHCO_26783 (11.00)
PHCO_27019 (11.11)
which should make the ulimit values for ksh to unlimited.

Revert
T G Manikandan
Honored Contributor

Re: datafile larger then 2048 Mo

This is a bug with oracle.check the attached metalink note

bruandet
Occasional Advisor

Re: datafile larger then 2048 Mo

THank you very much !
I install patch PHCO_26738 and I resolve my problem !
Fred Ruffet
Honored Contributor

Re: datafile larger then 2048 Mo

In a more general way, try to be compliant with the metalink document ID 169706.1. It is oftenly updated and is a good references for needed patches.

Regards,

Fred
--

"Reality is just a point of view." (P. K. D.)