cancel
Showing results for 
Search instead for 
Did you mean: 

dual boot problem

SOLVED
Go to solution
Michael Bright
Occasional Contributor

dual boot problem

I currently have a dual boot with Win XP and Win 2003 Server. The Win 2003 Server was a trial version and has expired. I still get the two options to boot to either OS at startup. I want to delete the partition with the Win 2003 OS but am concerned it may prevent booting at all. Even though I can "see" the boot.ini file from XP, My Computer, Properties, Advanced, Settings, Edit -it shows the TWO OSs, I cannot find this boot.ini file when I do a search. I see another boot.ini file in the Partition Magic folder, but it only has ONE OS listed. I am concerned that the relevant file may be on the Win 2003 partition and I will delete it. Why can't I see the boot.ini file that is visible from the Edit button in XP?
Here is info from the Edit button:
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Windows Server 2003, Enterprise" /fastdetect
Here is the info from Partition Magic folder:
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect
5 REPLIES
Marcin Golembski_1
Honored Contributor
Solution

Re: dual boot problem

You cannot find boot.ini because by default it is a hidden system file. To be able to find it you have to open Windows Explorer, opent Tools menu, choose Folder Options, View tab and on the list of options select 'Show hidden files and folders' and uncheck 'Hide file extensions for known file types' and 'Hide protected operating system files'.

After that you should be able to see a few more files in the root of your WinXP partition. The files that must be present to be able to boot from that partition are ntldr, ntdetect.com and boot.ini. One more thing to check is whether your WinXP partition is active, i.e. if this is the partition your computer boots from. Right-click 'My Computer', select Manage and click Disk Management, then right-click your WinXP partition and see if 'Mark Partition Active' option is grayed out. If it is, the partition is active and you should be OK. Just remove the:
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Windows Server 2003, Enterprise" /fastdetect
line from boot.ini, and do what you want to the Win2003 partition.

Bruno Ganino
Honored Contributor
Michael Bright
Occasional Contributor

Re: dual boot problem

OK thanks Marcin. I found the correct boot.ini file in the Root of the XP installation. I did have the "Show hidden files" option selected but I was looking for it via the Search function. Obviously search doesn't find hidden files - logical enough I suppose. Also'Mark Partition Active' option is grayed out.
I will follow your suggestion and delete that line and then the partition.

Thanks again.
Chad Miller_5
Trusted Contributor

Re: dual boot problem

By default, you're right, the search option will not look for system files, but you can click on "Change Preferences", "Change files and folders search behavior", click the "Advanced" radio button. When the search menu comes back up, you will see some check boxes for searching system folders, hidden files, etc.
Michael Bright
Occasional Contributor

Re: dual boot problem

Thanks Chad. I wasn't aware of that. That probably explains why I haven't been able to find that "_ethan" file using "find file" when I know a computer is infected with that macro virus.

When do you stop learning in this game? The other side of the grave I suppose.

Cheers