General
cancel
Showing results for 
Search instead for 
Did you mean: 

error message on console HP 9000 R380 HPUX 10.20

driss
Advisor

error message on console HP 9000 R380 HPUX 10.20

Hi all,
We have HP9000 R380 (HP-UX 10.20) connected to hardmatrix printer (PRINRONIX 5000)in // mode named "MAGNA"
our Pb we can't print now with message console
"/etc/1p/interface magna 97:test:files paramets with this command failed...
we tryed
# insf -e
# lp -dmagna /etc/hosts no printout ==>printer ONLINE!
have someone ideas to resolve this issue!?
thanks.
4 REPLIES
sujit kumar singh
Honored Contributor

Re: error message on console HP 9000 R380 HPUX 10.20

hello,
driss

if the printer is commected to the Server on the parallel Interface dirctly .. can u check if the spooler is running on the server

give the command

#lpstat -t

if schedular is not running please restart the schedular using the command
#lpsched

also u can give the command as

#lpstat -o

to see the status of the O/P jobs for the printer.


just if possible can u post the O/P of the commands lpstat -t and iosan -fn


Regards
Sujit
driss
Advisor

Re: error message on console HP 9000 R380 HPUX 10.20

Thanks SUJIT,
I have got this pb error message "/etc/lp/interface/magna[97]:test:specify parameter with this command"
after sending:
#lp -d magna /etc/hosts
we have this:
" #@(#)hosts *revision :1.9.214.1 **date96/10/08 13:
in fact the site of this server is far from us about 80klms i will be tomorrow to see this and feed back to you my action
yhanks
Michael Mike Reaser
Valued Contributor

Re: error message on console HP 9000 R380 HPUX 10.20

Your printer interface script file /etc/lp/interface/magna has an error on or around line 97. It's likely doing something along the lines of

if [[ -something ${UndefinedVar} ]]

where it's de-referencing a variable that never got a value within your script.
There's no place like 127.0.0.1

HP-Server-Literate since 1979
driss
Advisor

Re: error message on console HP 9000 R380 HPUX 10.20

Hi all,
you acn close this case!
We have reinstalled printer driver with direct // mode first.
and the setup printer was returned to the default factory =port 1394 no //or serial connection, we can add,on setup printer at control page, CR and LF was disabled ! on the analysez setup,so we enabled them.
all works fine now
thanks